WordPress.org

Forums

Can't change image link, keeps reverting. (7 posts)

  1. scott_see
    Member
    Posted 3 years ago #

    [caption id="attachment_265" align="alignnone" width="300" caption="Take a Video Tour of Many of Our Houses"]<a title="Video Tours" href="http://www.jlscolumbiagorge.com/sample-page/youtubescreenshot-614px/" rel="attachment wp-att-265"><img class="size-medium wp-image-265    " title="Take a Video  Tour of Many of Our Houses" src="http://www.jlscolumbiagorge.com/wp-content/uploads/YouTubeScreenshot-614px-300x182.jpg" alt="Take a Video  Tour of Many of Our Houses" width="300" height="182" /></a>[/caption]

    I'm using Thematic theme with TinyMCE editor. I want to link this image to a page, but every time I change it, it reverts back to what you see above. I try clicking on the image and editing the Link URL. I try clicking on the link icon in the editor. Nothing sticks. Something is forcing the Link URL to revert back to the default.

    How do I override this? It shouldn't be this difficult to link an image to what you want to. Even if I edit it in HTML view, the <a href code reverts back. I'm really stuck here.

    The site is http://www.jlscolumbiagorge.com/
    I'm trying to link to http://www.jlscolumbiagorge.com/video-tours/

    Thanks,

    Scott

  2. scott_see
    Member
    Posted 3 years ago #

    I would assume this is a Thematic theme issue. Would anyone agree/disagree?

    Thanks,

    Scott

  3. flub
    Member
    Posted 3 years ago #

    I have the same issue.

    Using Newsprint theme.

    I don't know why we wouldn't be able to change the raw HTML in one Theme and not another (it's not something you see or style), but then there's a lot I don't know.

  4. scott_see
    Member
    Posted 3 years ago #

    I figured it out. With TinyMCE editor, there's an option to override WordPress' automatic link thing. It's called "Advanced Link." I highly recommend TinyMCE and I highly recommend using this Advanced Link. It makes it tough to link to internal pages--you have to do it manually--but it does fix my problem. WordPress is awfully aggressive about linking images the way it wants to. Very aggressive.

    Scott
    http://scotts-favorites.com/

  5. flub
    Member
    Posted 3 years ago #

    Thank you for that. I see TinyMCE is a plugin, I'll try it out.

    Just saw that the symptom doesn't arise with the default theme btw.

  6. scott_see
    Member
    Posted 3 years ago #

    Really? So the theme is messing things up. Interesting. I hate it when scripts get aggressive about doing things their way.

    Scott

  7. scott_see
    Member
    Posted 3 years ago #

    By the way, I added TinyMCE 'cause the default editor is awfully aggressive about stripping out whitespace.

    Scott

Topic Closed

This topic has been closed to new replies.

About this Topic