Support » Fixing WordPress » Can’t change home page

  • I am trying to change my homepage from (example), to I’ve tried doing it both ways, first by keeping the wordpress directory and just transferring the index.php and the htaccess to the root file.

    This didn’t work, so I then moved all the wordpress core files from all the subdirectories into my root file, but it still didn’t work. This is the error message I’m getting:

    Warning: main(./wordpress/wp-blog-header.php): failed to open stream: No such file or directory in /home/awesome-/public_html/WordPress/index.php on line 4

    Warning: main(./wordpress/wp-blog-header.php): failed to open stream: No such file or directory in /home/awesome-/public_html/WordPress/index.php on line 4

    Fatal error: main(): Failed opening required ‘./wordpress/wp-blog-header.php’ (include_path=’.:/usr/local/lib/php’) in /home/awesome-/public_html/WordPress/index.php on line 4

    I’ve tried both methods at least 5 or 6 times, without any success. If anyone has any idea what I might be doing wrong, I’d appreciate it.

    One quick side note: after trying it several times, I decided to completely uninstall wordpress on my site and reinstall it to see if it would work. I noticed that I didn’t get a new htaccess in my wordpress directory, and that it was already in my root file. Is this normal?

    Anyway, if anybody could give me some direction, I’d appreciate it.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Have a look over this.


    I actually used those instructions, without any success. I might have some settings wrong I’m unaware of; for whatever reason, I’m still getting that error message.

    You don’t get htacces by install.
    What I’d do: set the permalinks to default, delete all htaccess files, if you have any – and see if it works. Then let’s go from there.

    You shouldn’t dupe questions, either.

    However, it looks to me like all you did was copy files over, and you didn’t edit anything else:

    Warning: main(./wordpress/wp-blog-header.php): failed to open stream: No such file or directory in /home/awesome-/public_html/WordPress/index.php on line 4

    It’s looking for it in “WordPress”, but you have “wordpress” as the directory name. Most directories are case-sensitive. The other errors would probably right themselves if you fixed that.

    And Moshu is right – .htaccess doesn’t come with the installation. usually your host will provide you with one, but if not, you make one yourself.


    I tried those suggestions, along with doodlebee’s about channging the case of the W, but I’m still getting the same error message. Not sure what to do…

    Actually, it is W and P (WordPress is not equal with wordpress).

    And where is now your installation? In the root? In a folder?


    Sorry for the late reply. I changed both the W and P, but it still didn’t work. The rest of my core files are still in the wordpress folder, but the index and htaccess are in the root.

    I also went in and updated the permalinks to the default, and copy and pasted that address into the hataccess, which was ( ) Is this the right address? After doing that, now I get this error message:

    I encountered an unrecoverable server error. Please go back and try again.

    I can’t even get into the administration area anymore, and the entire site seems to be down. It must have something to do with what I copy and pasted into the htaccess.

    You don’t copy/paste anything into the htaccess file – that’s definitely wrong! The file is either written by WP itself or WP shows you what do you need to copy into it.
    However, what I said: delete/remove the htaccess file from the server. Set the permalinks to default.
    The other thing is: when you have a setup with the WP files+directories in a subfolder (wordpress) you need the “short and sweet” index file BOTH in the root and the wordpress folder! If you read the instructions for Giving WordPress its own Directory (as you claim you did) it says clearly: copy the index [and htaccess, if exists]. Not to move – but copy!

    I’m gonna put my 2 cents in here and back up moshu’s statement there. *especially* about the .htaccess.

    I’m thinking maybe you need to go back and re-read those instructions again. But definitely delete your .htaccess file, and reset your permalinks to default. That’s a start. The way you’re going you’re gonna seriously mess something up soon!

    Sorry, I’m not very tech savvy (this is my first blog) but I’ll try deleting the htaccess file (the permalink already is at default. By the way, I guess I wasn’t very clear earlier-I didn’t move the index file, it is still in both folders.

    Finally got it to work! Thanks both for your help, and sorry for all the hassle.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can’t change home page’ is closed to new replies.