Support » Plugin: Memphis Documents Library » Can’t change file data through batch editor

  • Resolved tecmetro70

    (@tecmetro70)


    Hi!

    Let’s say I have a pdf file named “XYZ”. I want to update this file, by using “Manage Versions” and also change it’s name to “XYZ-1”. So I do that. When I go check the source folder, my new file is there, with the new name. But in the mdocs list through wordpress dashboard it’s not there. And it does not show in the “manage versions” menu. Even when I try using “Batch edit” options to change the name of the file, it won’t work.
    So I have to trick the system, by changing the new file name to the old name. That way my file is updated but it’s with the old name…which sucks..

    I’ve had a similar problem weeks ago, and I fixed it by restoring a backup. But I don’t wanna do that again…is there a fix?

    Thanks so far!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author bhaldie

    (@bhaldie)

    that is not how mDocs works. If you want change the current file you would click on the Manage File link then upload the new file.

    so in your example you have a file named XYZ the new file is XYZ-1 click the “Mange File” link then upload the new file XYZ-1. The filename will update to the new file name and the old file will be archived under the “Manage Version” link.

    tecmetro70

    (@tecmetro70)

    yeaah I’m sorry. I’m from Brazil and I’m using mDocs in portuguese

    I trieid to translate the name of the option, but I did it wrong

    I did exactly what u said. “Manage File> Upload new file and gave it a new name> Then clicked Update File

    But the file was not updated and the name didn’t change. But in the source folder, the new uplaoded file is there with the name I gave it.

    Plugin Author bhaldie

    (@bhaldie)

    something is wrong with the upload process then. Or the data in mysql is incorrect.

    please disable all other plugins and use a default theme and try to upload an again.

    tecmetro70

    (@tecmetro70)

    So…I have disabled all plugins and change the theme to the default one…But it was no use…still the same problem.

    If only I could change the name of the file…cause when I change it through Batch Edit link, it has no effect whatsoever..

    I’m realy grateful for your support so far..

    Plugin Author bhaldie

    (@bhaldie)

    So to narrow things down, you can upload new files to mDocs but you can’t update already existing files?

    tecmetro70

    (@tecmetro70)

    I could upload new files, but they would only show in the source folder, /uploads/mdocs.

    But…..funny story

    It’s all fixed now. I can upload new files and rename them. And nothing changed since friday, when I had this problem….it’s all good now

    There must have been some change…but now it’s all fixed

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.