WordPress.org

Support

Support » Themes and Templates » [Resolved] Can't change colors in customize

[Resolved] Can't change colors in customize

  • I’ve just downloaded and installed Ridizain and I’m liking the way things are looking on this theme. However, when I try to customize the colors (under Appearance>Customize>Colors) absolutely none of the colors I choose work. I would like to remove the bright green that is dominant and replace it with colors to match my logo. Can you shed light on why the option is there to change colors but does not work? Thanks…

Viewing 15 replies - 1 through 15 (of 17 total)
  • Theme Author Brian Harris

    @zgani

    Thank for choosing and liking Ridizain.

    The options are to facilitate the ease of color change and they all work as intended on my servers.

    Do you have a cache plugin installed? If so you may need to clear it.

    Other things to try is set the desired color for the desired elements, save and exit the customizer. Then refresh the front end a couple of times and then revisit the customizer to continue with the settings.

    Details of the elements that you have tried to change and didn’t work plus a link to the site would be very helpful in assisting you debug any issues.

    Regards,
    Zulf

    Thanks for replying. I cleared my cache and then returned to the customizer menu to change colors. Still will not change. Here is my site: http://www.vhcreativephoto.com.

    I want to change the green hover and the green sidebar colors to match my logo. I’m using ColorZilla to map the colors in my logo, then pasting in the code on the customize area.

    I would send an attachment of a screenshot but don’t see a way to do that here in the forum.

    Theme Author Brian Harris

    @zgani

    OK, I get what you mean.

    The control for that is the accent color. This section is sanitize to accept only allowed data to be entered so when you say

    I’m using ColorZilla to map the colors in my logo, then pasting in the code on the customize area.

    I’m wondering what values are you trying to input in the field?

    The field will only accept hexadecimal colors i.e #00000 or 000000

    If you’d like to share screenshots you can drop them in my dropbox here: http://wpdefault.com/drop-share/ – you’d have to be registered and logged in to so.

    Sorry, should have been clearer on the “code” color thing. ColorZilla will allow me to select a color on my screen and then it provides the hexadecimal color #’s…much like Photoshop does with the eyedropper tool.

    I pasted the hexadecimal numbers in, then even tried typing the given numbers into the field and nothing worked. None of the color changed, and I tried several.

    I’ll send a screenshot shortly. Thanks!

    Theme Author Brian Harris

    @zgani

    Got the screenshot and all on input side looks good.

    Could I ask if you have a cache plugin enabled on the site?

    Also try saving the settings, exit the customizer, visit and refresh. Then revisit the customizer, make another change and save then refresh the screen. The idea here is to help clear the theme’s transients and see if they are the ones causing the issue.

    I use Google Chrome as my browser of choice. I did clear the cache this morning as you first suggested. Closed the browser, reopened, then cycled through making one change, closing, refreshing, visiting the site and seeing no changes.

    I originally changed all colors at once, then went back and changed each separately and saved/published.

    Nothing…

    Theme Author Brian Harris

    @zgani

    I’m just looking at your site’s source code and it shows that the custom CSS from the customizer is being loaded before the default style.css which is the opposite of what should be happening.

    Have you made any changes to the theme?

    If not then could you try and deactivate active plugins and test by firstly checking if the theme settings work. And if they do then reactivate the plugins one at a time while checking the effect.

    The only change I made was to upload my logo. I’m not versed in code so I don’t dabble with anything there. I do know that I updated a couple plugins from my dashboard just recently, but that was before I installed this theme.

    Let me try your suggestion and I’ll get back to you. Thanks!

    Theme Author Brian Harris

    @zgani

    Closing thread as you no longer use Ridizain for your site.

    But you ever need assistance with theme at any time in the future please feel free to raise a new thread.

    Regards,
    Zulf

    Hi Zulf, thanks for this great entry. I am having the same problem, I want to change the green accent color to something else and it won’t seem to retain a change. Even a white would be fine for now. Any suggestions would be appreciated. The staged site is at http://44s.osaadeldin.net/wordpress

    Thank you,

    Theme Author Brian Harris

    @zgani

    @grindstone44s – are there any specific element(s) you want the changes applied to?

    I believe I missed out the menu hover background plus the new Social link over color – going to include these in the upcoming update.

    Regards,
    Zulf

    Thanks for the upcoming update. I got really frustrated when nothing would work for me on the color changes (after walking through every step you suggested) so I took it down and moved to something else. I do like this theme, though, so maybe I’ll take a second look when the update comes out.

    Thanks Zulf, I am going to launch the site soon, do you have an ETA on the update so I can fix the green? Thanks

    Theme Author Brian Harris

    @zgani

    @grindstone44s – version 1.0.18 has been approved and is waiting in the que to pushed live. Should be any day now but it can take up to 7 days depending on how busy the theme review Admins are.

    Should you need an advance or a past version copy you can always get any of the submitted version here: http://wordpress.org/themes/ridizain/developers/

    Let me know how it goes and if there’s anything else I can help with.

    Regards,
    Zulf

    Thank you. I downloaded the 18 zip file but it won’t install using the theme upload function. Is there a trick to it?

    Also once I get this ver installed, which custom color option is going to change the green menu background?

    Thank you.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Can't change colors in customize’ is closed to new replies.