WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Can't change category on a new post.

[Resolved] Can't change category on a new post.

  • Hi,

    A few days ago, I posted an article on my site. It goes smoothly as planned. I finished another article and I tried to save it in another category. What happened next surprised me. I’ve tried ticking the box of the category but after saving the draft, it goes to the default category(Uncategorized). Tried several times to save it but nothing happened, just goes back to the default category. I tried disabling the plugins but no avail.

    Any ideas on what’s the problem?

Viewing 15 replies - 1 through 15 (of 15 total)
  • All of a sudden I started having that problem. Posted new material this morning with no problem.

    All of a sudden this afternoon all my posts refuse the categories I give them and go to the default, “Uncategorized.”

    I tried deleting my cache and also used my provider’s dashboard controls to repair and optimize all my databases (which went off without a hitch.)

    Also noticed that if I take an older/previous post and try to change the categories it immediately defaults to “uncategorized.”

    tavaresv,

    Thank you for the reply, so have you fixed the problem? The symptoms are same.

    Sorry, no. Am having the same problem. Do not know how to fix.

    I am suddenly having the same issue. I’ve tested three different websites that I’ve got set up in WordPress and each one is having this problem. What’s going on?

    Are you hosted on BlueHost by any chance?

    I suspect a dormant bug has infected some code.

    Looks like we need a WP expert.

    Any moderators out there hear of this?

    And, no, I have Host Monster.

    Not to muddy the discussion but I just started experiencing the same issue along with a php.ini error message about “File is empty. Please upload something more substantial.” when attempting to upload small file. Both issues happened at the same time which I thought odd.

    Unfortunately I have nothing at all to add to the discussion except that all of my sites began doing this this afternoon as well.
    The good news is that it seems to be either a WordPress issue, or a bluehost/hostmonster issue (I actually think that they use the same servers), and it will be fixed for us if we’re patient.

    and 5 minutes after I posted it appears to have been fixed. I haven’t tested all of my sites yet, but the 2 that I checked are working just fine.

    Looks like it cleared up for me, too.

    WTF?!?!?!

    Why? How?

    Are you on bluehost or hostmonster?

    Hostmonster

    Bluehost for me. It is also fixed now for me. I was a bit freaked out, thinking it might be a virus that entered the system.

    Any expert can explain how or why it happened? I guess people should know this…

    It could be about our hosts “Hostmonster and Bluehost” being the culprit.

    Anyhow, it’s resolved for us. Hopefully it doesn’t happen again. It truly freaked me out!

    I suspect you’re right. But I still would like to know how it happened.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Can't change category on a new post.’ is closed to new replies.