Support » Plugin: All-in-One Event Calendar » Can’t change Calendar theme after upgrade to 2.5.39

  • Hello,
    after upgrading from 2.5.32 to 2.5.39, calendar theme was back to the default one.
    I tried to reactivate my custom theme, without success.

    No error in the logs, no errors on screen.
    Just after click on “activate” theme, page reloads and default theme is on.

    Tried also with 2.5.40 version (latest) but issue remains.

    Reverting back to 2.5.32 solves the issue.

    NB: Activating any of the other themes that comes with the plugin works, is just activating my custom theme (built copying some of the vortex theme files into the wp-content/themes-ai1ec folder) that does not work.
    did you change anything on how new templates can be made?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • I am having the exact same issue. Had to revert to 2.5.32 as well. Tried 2.5.38 and 2.5.40 with no luck. Haven’t tried any other versions between 2.5.32 and 2.5.38. I’m also using a customized theme. I can send customized theme via email if that would help.

    Update, 2.5.37 is working for me, but not 2.5.38 nor 2.5.40.

    Thread Starter bluantinoo

    (@bluantinoo)

    Thread Starter bluantinoo

    (@bluantinoo)

    It looks like it’s happening because (in the line I linked in previous comment) it looks for a less.sha1.map.php file, that should be in your calendar theme in wp-content/themes-ai1ec/YOURTHEME

    This file (looks like) contains default values for calendar theme options, as they appear on “Wp-admin -> Events -> Theme Options”

    But the file it’s not there… never has been there. Now it has to be there.

    To fix, and being able to switch to your theme, you need to add that file, you can just copy from another default ai1ec theme, like Vortex.

    Unfortunately, during all these processes, my previous configurations of the calendar theme options are gone 🙁

    WTF?

    • This reply was modified 1 year, 9 months ago by bluantinoo.
    • This reply was modified 1 year, 9 months ago by bluantinoo.

    Adding the file seems to work. Thanks. Luckily for us, we use a custom CSS file instead of the Calendar Theme Options. Makes sense it would reset. Seems like the updated version is pulling/updating that file instead of however it was updating before.

    I guess the VERSION 2.5.38 “Fixed: Invalid file location for the current theme options would throw HTTP 500 error on specific server environments.” is what triggered the need for the file inclusion. Would recommend that the plugin authors clarify as @bluantinoo noted it now requires calendar theme designers to include said file.

    I was having the same problem: unable to activate a custom theme, though the less.sha1.map.php is present. Turns out it was because my theme folder had a numeral in the directory name, and apparently the plugin was removing it in some kind of sanitizing operation and then couldn’t find the files.

    So, a word of warning: for anyone else who might be tempted to name their custom theme something like ai1mytheme — don’t do it! That digit will cause trouble!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t change Calendar theme after upgrade to 2.5.39’ is closed to new replies.