Support » Plugin: Scriptless Social Sharing » Can’t change any settings

  • Resolved Leslie P

    (@lesstx)


    Installing and activating plugin is fine, and the buttons show up at the end of posts, default configuration seems to work ok.

    I am entirely unable to modify any settings. I get:
    This page isn’t working
    <mysite.com> is currently unable to handle this request.
    HTTP ERROR 500

    I’ve installed the plugin on two different sites and have the same problem.

    Possibly related – no Pinterest button shows up. I have buttons for Twitter, FB, G+, Linked In and email, in that order.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Robin Cornett

    (@littlerchicken)

    Hi Leslie! I’m sorry you’re encountering this issue. Unfortunately, I’m not currently able to replicate it. Can you give me more information about the environment(s) where you’re installing the plugin? Knowing the PHP version might be helpful, and what plugins/theme are running, and the URL. If you do not want to share that data here, feel free to contact me directly with it.

    If you can track down logs about the error, that may give the most information (your host may be able to help with this).

    The Pinterest button not showing is likely unrelated–that’s usually due to the plugin not being able to find an image to use for the button (an image is required for the Pinterest button), as described in the FAQ.

    I’m having the same issue.

    Saving options just ends up in a 500 server error.

    I’ve tried it with all plugins deactivated, which means it’s a SSS error of some kind.

    The site is on a simple shared server, running PHP 7.0 (not sure, could be 5.6.30, as phpmyadmin is showing) and MySQL 5.6.41.

    Thanks.

    I’ve downgraded to version 2.1.1 and the options save with no issues.

    Robin,
    I sent you a PM via your website with my URL and list of plugins, but the basic stuff is
    PHP 7.0.29 simple twenty sixteen theme, and the problem persisted even with all plugins disabled.
    I really appreciate the prompt attention!

    Plugin Author Robin Cornett

    (@littlerchicken)

    Thank you both for reporting this. Alvaro, I’ve asked Leslie if she can replace this file:

    
    https://github.com/robincornett/scriptless-social-sharing/blob/develop/includes/settings/class-scriptlesssocialsharing-settings.php
    

    and see if that resolves the issue. If it does, I used an include when I should have used an include_once, and it seems to fail in some situations, but not all. If you’re able to FTP and swap out just the one file (if you go back to 2.2.0) and see if it resolves and can let me know, I would appreciate it.

    Thank you both for your patience.

    I was having the same problem, Robin.

    That code change fixed it for me – awesome as always.

    When are you going to add a “buy me a coffee link”? 😉

    Thanks @littlerchicken!

    I’ve swapped that one file and options seems to be saving OK now.

    Plugin Author Robin Cornett

    (@littlerchicken)

    Thank you everyone for checking on this and for your patience. I’ve just released version 2.2.1 which includes this fix.

    You’re awesome! Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.