Support » Plugin: WP Security Audit Log » Can't change alerts pruning option

  • The “Security Alerts Pruning” option keeps set to “Keep up to XX alerts”, even when I try to set it to “Delete alerts older than ..”

    I inspected the HTML and realized that both radio buttons #delete1 and #delete2 have a checked=”checked” attribute. So it’s probably saving the correct option, it’s just not being displayed correctly because of the conflicting attributes.

    Trying to set this option to “none” also doesn’t work. In this case, only the #delete2 radio button has the checked attribute in the code.

    I hope this helps to identify the problem.

    https://wordpress.org/plugins/wp-security-audit-log/

    Edit: forgot to mention that this is similar to the problem reported in this thread. On my test server I could get it fixed by disabling and enabling the plugin again, but on my production server it didn’t work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    HI Hvianna,

    Thank you for reporting this issue.

    It seems there is something wrong with the pruning of security alerts and we are looking into it as we speak.

    In the meantime if you can use the pruning option “by time” rather than “by number of alerts” this should work without any problem.

    Can you please advise?

    Thank you.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    HI Hvianna,

    Just to advise you that we should have a fix in the next update of the plugin, which is scheduled for early next week.

    Thank you for letting me know, I’ll look forward to it!

    Plugin Contributor robert681

    (@robert681)

    HI hvianna,

    We just released a new update for WP Security Audit log but unfortunately we were not able to address your issue, sorry for that. Though we will for sure issue a fix for your problem next week or no later than the week after.

    Should you have any queries do not hesitate to get in touch.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    HI Hvianna,

    Sorry forgot to update you but the latest version of WP Security Audit Log addresses this issue.

    Thank you for using the plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't change alerts pruning option’ is closed to new replies.