Support » Plugin: All In One WP Security & Firewall » can’t block site.ru as user a refferer

  • I have added site.ru to the blacklisted user agents previously but it still appeared in 404 logs. So, I can’t block domains (referrers) with this plugin?!

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, do you know the IP address?

    Thank you

    Thread Starter david2432

    (@david2432)

    It comes with many different IPs. If I block it by IP then I should monitor it everyday and block all the IPs it will show, this way I might overflow plugin.
    Why user agent blocking not working? I added it in the box in Blacklist Manager>User Agents as site.ru Maybe I did this wrong?!

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, can you block by IP range?

    Regards

    Thread Starter david2432

    (@david2432)

    Its IPs are various range, that,s the problem. If I block all I might block real users. I will still try to block it by IPs as a last stand because I really like this plugin and don’t want to switch to another yet.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I have another suggestion for you. Would blocking the country work for you?

    Regards

    Thread Starter david2432

    (@david2432)

    ) I don’t want to block whole country (at least till it gets too bad). I just wonder, if it’s not hard for you to ask developers of the plugin about user agent blocking problem, maybe it’s a bug in current version…

    Thank you.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I understand your situation. However before I ask the developers can you let me know if you also have one of the following features enabled?

    Completely Block Access To XMLRPC:
    Disable Pinback Functionality From XMLRPC:

    These can be found in WP Security -> Firewall -> Basic Firewall Rules.

    Thank you

    Thread Starter david2432

    (@david2432)

    Yes, I have enabled both.

    I think the easiest way to block site.ru is using RewiteCond / RewriteRule in .htaccess:

    RewriteEngine On
    RewriteCond %{HTTP_REFERER} site\.ru
    RewriteRule .* - [F,L]
    Thread Starter david2432

    (@david2432)

    Thanks, I understand but then I should do this for every domain I encounter as malicious and I might break something in htaccess. Would be better if the plugin could do this for me.

    I have the same issue with another domain and I agree with @david2432, the plugin should let us add some domain in the blacklist. Something like domain.tld or *.domain.tld.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    Yes, I have enabled both.

    You only need to enable one feature not both.

    Do you also have one of the Brute Force features enabled? For example: Rename Login Page.

    Have you also enabled 404 Detection feature?

    Thank you

    • This reply was modified 6 months, 3 weeks ago by mbrsolution.
    Thread Starter david2432

    (@david2432)

    Yes, “Rename Login Page” is one of the feature I liked in this plugin and enabled it, also as I already mentioned above – I see site.ru appearing in 404 logs, so I have enabled 404 detection.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    What time length have you added to the 404 lockout?

    Have you also enabled Block Fake Googlebots: feature?

    • This reply was modified 6 months, 3 weeks ago by mbrsolution.
    • This reply was modified 6 months, 3 weeks ago by mbrsolution.
    Thread Starter david2432

    (@david2432)

    404 lockout – 60 min. (As I understand this only works if I manually block IP from 404 log)
    Fake Googlebots – enabled.

    site.ru appearance is not sequential. as I noticed before, it appears sometimes, a few days after. Now, 1 day past after I deleted 404 logs and waiting for it to show again…

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘can’t block site.ru as user a refferer’ is closed to new replies.