Support » Plugin: BackWPup - WordPress Backup Plugin » Can't backup large folder

  • I can backup small folders without any problem. But I can’t backup my uploads folder. It’s about 480 mb. While trying to backup, it restarts several times due to inactivity, and then says it finishes and uploads to Amazon S3. But the file that it uploads is only about 15mb, so it’s incomplete.

    I’m using BackWPup 2.1.16, and wordpress 3.4.2. I’m also using W3 total cache, but I believe that you fixed that incompatibility issue in a previous version.

    I thought perhaps it was a timeout issue with my server, so I contacted my web host, and they put a php.ini file in my root folder that has this:

    memory_limit = 2048M
    max_execution_time = 259200
    max_input_time = 259200
    upload_max_filesize = 1536M
    post_max_size = 1536M

    But I still can’t backup my uploads folder. Here’s the latest log file:
    2012/12/02 15:28.52: [INFO]: BackWPup job: 4. Uploads; FILE
    2012/12/02 15:28.52: [INFO]: BackWPup cron: 0 4 * * *; Mon, 3 Dec 2012 @ 04:00
    2012/12/02 15:28.52: [INFO]: BackWPup job started manualy
    2012/12/02 15:28.52: [INFO]: PHP ver.: 5.2.17; litespeed; Linux
    2012/12/02 15:28.52: [INFO]: MySQL ver.: 5.5.28-log
    2012/12/02 15:28.52: [INFO]: curl ver.: 7.24.0; OpenSSL/1.0.0
    2012/12/02 15:28.52: [INFO]: Temp folder is: /home/USERNAME/public_html/blog/wp-content/plugins/backwpup/tmp/
    2012/12/02 15:28.52: [INFO]: Backup file is: /home/USERNAME/public_html/blog/wp-content/plugins/backwpup/tmp/backwpup_uploads_2012-12-02_15-28-52.tar.gz
    2012/12/02 15:28.52: 1. try for make list of files to backup….
    2012/12/02 15:29.12: 10582 files with 484.64 MB to backup
    2012/12/02 15:29.12: 1. try to create tar.gz archive file…
    2012/12/02 15:43.38: [ERROR] Job restarted, because inactivity!
    2012/12/02 15:43.38: 2. try to create tar.gz archive file…
    2012/12/02 15:55.56: [ERROR] Job restarted, because inactivity!
    2012/12/02 15:55.56: 3. try to create tar.gz archive file…
    2012/12/02 16:08.01: [ERROR] Job restarted, because inactivity!
    2012/12/02 16:08.01: [ERROR] Step arborted has too many trys!
    2012/12/02 16:08.01: 1. try sending backup file to Amazon S3…
    2012/12/02 16:08.02: Connected to S3 Bucket: BUCKETNAME
    2012/12/02 16:08.02: Upload to Amazon S3 now started…
    2012/12/02 16:08.19: Backup transferred to
    2012/12/02 16:08.20: Job done in 2368 sec.

    But, the file was only about 15 mb. I also tried saving it just as a tar, but that didn’t help.

    Do you have any ideas of what I can do to backup a large folder? I don’t want to break it into smaller folders.


Viewing 5 replies - 1 through 5 (of 5 total)
  • I have a similar problem, but my files total size is almost 1.5GB, do you know how to change this, or exclude the folder with all this files.

    migelfg, when you set up a job, you can select while folders to include, and which ones to exclude. And there’s also a place right below that to exclude more folders–it says “Exclude more files/folders from Backup. For example, say you want to exclude the uploads for January, 2012. In that section you can put /wp-content/uploads/2012/01

    I tried breaking my uploads into smaller jobs. But my uploads folder for 2011 is a little over 200mb, and it won’t backup that either. I don’t want to have to break the years into smaller chunks also. I would end up with a lot of jobs to backup my blog.

    Plugin Author Daniel Hüsken


    sorry but this is dependent on the webhost.

    I try to find better and other ways to to make the Backup in one Job.

    Daniel, wouldn’t the php.ini file that my webhost put in my folder make it so that I should be able to backup large files?

    Plugin Author Daniel Hüsken


    Sorry, it is normely not only a php.ini setting. Because the stting that the job need will try to changed by itself.

    The Hoster has mostly a sofware that watches the Webserver prozesses and abort tham if they would or need to many resurces they set.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't backup large folder’ is closed to new replies.