WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] can’t automatically upgrade from 2.8 to 2.8.1

[Resolved] can’t automatically upgrade from 2.8 to 2.8.1

  • I guess I could try a manual upgrade but first I thought I’d ask if anyone else has any suggestions. When I click the “upgrade automatically” button nothing happens at all. When I try to manually go to the upgrade URL (update-core.php?action=do-core-upgrade) I get a message that says “Are you sure you want to do this?” but no way to say yes. I tried overwriting the wp-admin & wp-includes w/ fresh copies of 2.8 (did not delete them first). That didn’t help. So, I guess the next step is to delete them and try the manual upgrade…

    On this site the “Search Plugins” button also doesn’t work and neither does Lightbox2. Deactivating all plugins does not solve the upgrade problem.

    Thanks

Viewing 15 replies - 1 through 15 (of 19 total)
  • Also tried completely deleting & replacing the 2.8 wp-admin & wp-includes folders. No help.

    If it matters, this site is installed on GoDaddy hosting and is installed in the root folder of the domain (GoDaddy’s automatic installer lets you do that, but that is something that makes it different from all the other WP sites that I maintain).

    I have a very similar problem. When I try to upgrade to 2.8.2 (I upgraded to 2.8.1 manually), I get this error:

    Warning: copy(D:\Hosting\4466358\html/index.php) [function.copy]: failed to open stream: Permission denied in D:\Hosting\4466358\html\wp-admin\includes\class-wp-filesystem-direct.php on line 131
    
    Warning: copy(D:\Hosting\4466358\html/index.php) [function.copy]: failed to open stream: Permission denied in D:\Hosting\4466358\html\wp-admin\includes\class-wp-filesystem-direct.php on line 131
    
    Could not copy file: D:\Hosting\4466358\html/index.php
    
    Installation Failed

    My blog is also hosted by GoDaddy and installed in the root folder. I’m using PHP5.x through Windows (as opposed to Linux). GoDaddy says there doesn’t seem to be a problem on their end but I’m not so sure about that. They gave me a link to one of the Docs here on upgrading using Subversion but I don’t think I can do that since the blog’s been installed in the root folder.

    Any suggestions to help us out?

    I do have to wonder if WordPress just “doesn’t like” being in the root folder. I upgraded to 2.8.2 manually but the “Search Plugins” and “Update Automatically” buttons still don’t work. Nothing happens at all when I click them. Neither of the Lightbox plugins work on this site either.

    I don’t think that’s the problem. I have WP installed in the root folder of another domain (hosted by SiteFlip) and I haven’t had any problems upgrading it automatically.

    Automatic upgrade does not work on all the servers. Sometimes, it does not work at all..

    So its better to install automatically..

    Well, that’s annoying. Seriously, I hate GoDaddy. -.-

    Thanks for the info, ryans149. What do you mean, though, by “install automatically”? Do you mean something like the WordPress hosting GoDaddy offers?

    Oh sorry for the typo.. I meant install Manually 🙂

    It’s really not “better” to upgrade manually. Just more labor intensive, and it means that the client can’t do it himself.

    Whatever it is, it has something to do with the action of the button. The “Search Plugins” button doesn’t work either. Same deal. Nothing at all happens when you click it.

    I really think this is something to do with GoDaddy because the install on my other domain upgrades without any problems. I may try to get a hold of GoDaddy and see if I can figure this out. If I get any answers, I’ll be sure to post them here.

    Thanks. I’ll try that too.

    In my case the same client has another site on the same hosting account but not in the root folder of its domain and that one works fine. So far the common symptoms of the sites that don’t work are that they are on GoDaddy and in the root folder.

    @lalaith – One thing that seems odd to me about your error message is that it’s looking for files on your D drive and using a mix of forward slashes and backslashes in the path. It definitely seems to be looking in the wrong place for those files, although I can’t tell you why.

    Interesting to note that GoDaddy now offers “WordPress Hosting” with WordPress “pre-installed” (in the root folder).

    So far no help from GD email support. Their first response was that they could not support the issue and try moving the site to a sub-folder. I wrote back saying that since their new WordPress Hosting option offers WordPress pre-installed in the root folder it might behoove them to look into this as it is likely to come up again. Their response to that was that if I do not want to run WP from the root folder I should not use WordPress Hosting. No attempt to actually look into it or answer the question.

    Lalaith
    Member

    @lalaith

    Yeah, it is weird that it’s looking in the D drive. You can’t update your plugins automatically, can you? I don’t have any problems updating my plugins.

    That’s ridiculous. Does the WP Hosting at GoDaddy cost extra? Because if it does then I think GoDaddy’s not going to help with this issue. It may even be designed to force you to use the WP Hosting.

    My client’s hosting is up in October so I’m probably going to move it to another host. I’m not happy with GoDaddy at all.

    I can update plugins just fine. Anything that uses a link works. It’s just the Submit buttons like “Search Plugins” and “Upgrade Automatically” that do not work.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] can’t automatically upgrade from 2.8 to 2.8.1’ is closed to new replies.