WordPress.org

Support

can't update

  • Hello everyone,

    I having trouble updating my version of wordpress. When I try to auto-update, I get this error:
    Warning: copy(/homepages/22/d366503813/htdocs/app366503818/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in /homepages/22/d366503813/htdocs/app366503818/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Then, when I attempt to do it manually, I can’t delete the respective files (wp-includes, wp-admin, etc.) For some reason I don’t have the right permissions to do this. When I try to alter the permissions on my host, nothing happens. I’m doing this with 1&1.

    Any help and/or pointers would be greatly appreciated. Thank you!

    -Shaun

Viewing 3 replies - 1 through 3 (of 3 total)
  • You may want to contact your host first and ask them about resolving your file and directory ownership or permission issues for you. I would think that you should be able to edit or remove files that are located in your public document directory.

    Thanks for the prompt response ClaytonJames. Indeed, it was a problem with the host. Because wordpress was installed via 1&1, all of the files were locked. I had to manually reinstall WP to make the changes.

    Lesson learned: Don’t do one-click installations of WP with 1&1.

    -Shaun

    You’re welcome. I’m glad it turned out to be something easy to resolve.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘can't update’ is closed to new replies.
Skip to toolbar