Support » Plugins and Hacks » [Resolved] Can't authorize twitter account

[Resolved] Can't authorize twitter account

  • I’ve upgraded to the latest plugin version, created the consumer key on twitter’s site, but, when I try to ‘authorize twitter account’ — absolutely nothing happens.

    I’ve authorized the app on twitter, it shows as an app in my dashboard, and on the user account, etc.. But, I can’t make it see that in the WP plugin.



Viewing 15 replies - 1 through 15 (of 38 total)
  • Plugin Author Aaron D. Campbell


    Did you fill in the consumer key (and consumer secret) in wp-admin -> “settings” -> “Twitter Widget” under “General Settings”?

    I have the same problem… the consumer and secret keys are filled in with the correct data, but when I click “Authorize New Account” it brings up the page wp-admin/options-general.php?page=twitterWidgetPro&action=authorize&_wpnonce=c11733bc61 but nothing seems to happen.

    Yes. Consumer key/secret are entered correctly.

    Same problem here. Update plugin, fill-in the correct consumer key/secret. After click at button ‘authorize new account’ I’ve got an error-page. The message is (in Dutch):

    Ho daar!
    De “request token” voor deze pagina is ongeldig. Deze kan mogelijk al gebruikt zijn of verlopen omdat deze te oud is. Ga alsjeblieft terug naar de site of applicatie die je hierheen stuurde en probeer het nog eens, het was waarschijnlijk gewoon een foutje.

    The “request token” for this page is invalid. This may be possible are already used or expired due to too old.

    So, what now?

    sorry, have to say I am having the same problem as above users – enter the consumer key/secret and still the plug-in indicates (with a link) “you need to authorize your Twitter accounts”, but when I click on the link, I go nowhere. Can’t figure out the next step.

    Thanks for any assistance you can offer. btw, I am also willing to help with testing/feedback on the plug-in once it is operable. I am quite excited about using wordpress/twitter on my site.


    Same issue here! Hoping to get a resolution soon. I tried tweeting for help but have gotten no responses. When you filled in the info on the app page to get the key/secret, did you put your WP site for “website” (3rd field) and your Twitter account in the 4th field?

    Same here. Help!

    Plugin is totally not working. I’ve reset everything, tried again, set read/write, still nothing. It just simply won’t work.

    Are you fixing this?

    I am having the same problem. After updating the Twitter Widget Pro plug-in, I was prompted to re-enter my consumer key and consumer secret, which I did. Then I clicked Update Options and then clicked Authorize New Accounts. That took me to the api.twitter page where I clicked Authorize App. It then tried to take me back to my blog admin page, but instead a blank page appears. When I go to my blog, Twitter feed still isn’t showing up. Very frustrating.

    Having the same problem.

    Hard to believe no one is responding to these issues. I need my Twitter feed on my site, so I just switched to another plug-in.

    Throwing my hat into the mix. Same thing occurring here.

    Plugin Author Aaron D. Campbell


    Hey guys, first of all I’d like to say that I WILL look into this. I just ran tests on every server I currently have access to, and was able to authorize accounts on every one of them. Until I can reproduce the error I can’t fix it. Any additional information that you think it relevant would help.

    Also, to be clear and set reasonable expectations, it is NOT unreasonable that I haven’t responded here in 7 hours. This is a completely free plugin that I create, maintain, and support for free. If you think it’s “Hard to believe no one is responding to these issues” then please go ahead and find a different plugin.

    Thanks for responding Aaron. I’d be happy to get you whatever info you may need to help diagnose the problem.

    Feel free to email me directly at david (at) wolfsnap [dot} com (also, google talk at the same email). I can probably get you access to the site and you can poke around to solve the issue.

    Hi Aaron, let me know what you need and I am happy to provide the information.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] Can't authorize twitter account’ is closed to new replies.