Twitter Widget Pro
[resolved] Can't authorize twitter account (10 posts)

  1. Alahin
    Posted 3 years ago #


    I still can't authorize the twitter account on my page.
    I have tried using the Consumer and the Access token.
    The application type is on "Read Only" but is allowed to sign in using twitter.

    I do not get any error message when pressing authorize account, I just keep getting back to the page where I was


  2. hvdesign
    Posted 3 years ago #

    Same behaviour here when trying to Authorize new account

  3. gluecake
    Posted 3 years ago #

    The fix is explained more in this thread: http://wordpress.org/support/topic/cant-authorize-twitter-account?replies=32

    Just need to set your callback url to your own domain name - you change it under Settings tab in the twitter dev account

  4. Alahin
    Posted 3 years ago #

    I have it set to my own domain name, sorry that information i forgot.

    I tried the full URL (including the /website) and with and without www.

  5. hvdesign
    Posted 3 years ago #


  6. Alahin
    Posted 3 years ago #

    The changes did not resolve it for me. Anyone else an idea?

  7. Aaron D. Campbell
    Plugin Author

    Posted 3 years ago #

    Some people are having problems because their server has out of date CA certificates (what is used to verify that an SSL certificate is valid). Can you try the development version of the plugin which tries to work around that? - https://github.com/OpenRange/twitter-widget-pro/archive/master.zip

  8. Alahin
    Posted 3 years ago #

    Hi Aaron,

    It did not help. Tried it with multiple settings like i said before.

    Currently these are the settings:

    Application details:
    name: domain.ext
    Description: domain.ext
    Website: http://www.domain.ext/blog
    Application Type: read only
    Callback URL: http://www.domain.ext/blog
    Allow this application to be used to sign in to twitter: - enabled.

    Settings website:
    domain to access the website: http://www.domain.ext/blog
    Consumer key used
    Consumer secret used

    I hope this is enough information to confirm that the settings are good.

  9. DennisJP66
    Posted 3 years ago #

    I am confused. I just updated the plug in and it is asking me to set up my Twitter app key and authorize my Twitter account. What I don't understand is what I am supposed to put under Application Name and Application Description. What application? Is it my name? Please explain to this non-techhie. Thanks!

  10. Aaron D. Campbell
    Plugin Author

    Posted 3 years ago #

    There is actually a support thread here titles "Instructions for Non-Tech ppl for Twitter Authorization Issue" - http://wordpress.org/support/topic/instructions-for-non-tech-ppl-for-twitter-authorization-issue?replies=5

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Twitter Widget Pro
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic