Support » Plugin: Pardot » can’t authenticate

  • glenerd

    (@glenerd)


    If I put my credential in and hit save settings I get this error: The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.
    but I never get an email

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cliff Seal

    (@cliffseal)

    That’s a fairly generic WordPress error message. Are you able to look at your server’s error logs?

    glenerd

    (@glenerd)

    Yes. What should I be looking for?

    Plugin Author Cliff Seal

    (@cliffseal)

    Fatal errors generated at the same time that you see that error message.

    glenerd

    (@glenerd)

    Here are the server errors we found:
    [Sat Aug 31 17:06:14.824249 2019] [php7:error] [pid 1383] [client 172.16.1.48:28972] PHP Fatal error: Uncaught Error: Class ‘SimpleXMLElement’ not found in /var/www/html/simplenexus.com/sn/wp-content/plugins/pardot/includes/pardot-api-class.php:451\nStack trace:\n#0 /var/www/html/simplenexus.com/sn/wp-content/plugins/pardot/includes/pardot-api-class.php(128): Pardot_API->get_response(‘login’, Array, ‘api_key’)\n#1 /var/www/html/simplenexus.com/sn/wp-content/plugins/pardot/includes/pardot-settings-class.php(546): Pardot_API->authenticate(Array)\n#2 /var/www/html/simplenexus.com/sn/wp-content/plugins/pardot/includes/pardot-settings-class.php(409): Pardot_Settings->authenticate(Array)\n#3 /var/www/html/simplenexus.com/sn/wp-includes/class-wp-hook.php(288): Pardot_Settings->sanitize_fields(Array)\n#4 /var/www/html/simplenexus.com/sn/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array)\n#5 /var/www/html/simplenexus.com/sn/wp-includes/formatting.php(4720): apply_filters(‘sanitize_option…’, Array, ‘pardot_settings’, Array)\n#6 /var/www/html/simplenexus.com/sn/wp-includes/option.php(306): sanitize_option(‘pard in /var/www/html/simplenexus.com/sn/wp-content/plugins/pardot/includes/pardot-api-class.php on line 451, referer: https://simplenexus.com/sn/wp-admin/options-general.php?page=pardot

    Plugin Author Cliff Seal

    (@cliffseal)

    Got it. Are you able to enable simplexml on your server? This is usually on by default.

    I’ll add this to the list of things we need to improve from the old code base. It shouldn’t assume that module is active.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.