Support » Fixing WordPress » Can’t assign posts to categories

  • Greetings! I’ve searched and haven’t found an answer to this question, so I’m asking the group. I am new here, though, so please forgive me if I’ve somehow missed something obvious!

    I’ve got a new WordPress 2.0.4 installation running atop Linux (Fedora Core 5, PHP 5.1.4, MySQL 5.0.22). Just about everything works fine; I can administrate users, post entries, etc.

    I’ve created a few categories. That worked well, too. What I cannot do, however, is assign posts to categories. It looks like it’s working (checkboxes appear, etc.) but everything still winds up only in Uncategorized. This happens regardless of whether I assign a post to a category when creating it or try to categorize it later.

    Might anyone have suggestions to offer?


Viewing 4 replies - 1 through 4 (of 4 total)
  • Is javascript on in your browser for your site?

    Yes, it’s turned on. It’s working, too: the timed color-fade effects that are done using JavaScript are working just fine. This problem occurs using Firefox as well as generic IE6.


    More data: I’ve removed the entire WordPress installation and walked through the installation instructions a second time, paying particular attention to things like database permissions. I’m still having no luck: everything seems to work except for the fact that it’s impossible to assign posts to categories–either when writing the post or after the fact. Has anyone else encountered this?

    This problem just sucked away a few hours of my life. In hopes of sparing others: if you click within the 20 pixels on right edge of the blue bar you can edit the category (etc.).

    I tried using wordpress with
    Windows IE6
    Windows Firefox 1.5
    Mac Firefox 2.0
    Mac Safari 2.0

    and none of them showed any indicators to suggest the right 20 pixels are any different than the rest of the blue bar (which just reorganizes the post options).

    WordPress, dudes: I *love* your product. It’s incredible, really! But… an icon… or something, please. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t assign posts to categories’ is closed to new replies.