WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't assign author to post anymore (10 posts)

  1. arturmak
    Member
    Posted 4 years ago #

    Hi!

    Recently I upgraded from WP 2.9.2 to 3.0 and since then I can't change post's author, bacause WP doesn't display "Authors" dropdown menu anymore... I run website with many contributors, so it's very important for me to have a possibility to choose the author of post.

    Is this caused by merging single user WP with WP MU since WP 3.0? Is there any solution to that problem? Any help will be appreciated :)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the 2010 theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. arturmak
    Member
    Posted 4 years ago #

    Thanks for advice, Esmi. I deactivated plugins, switched the theme but nothing happened. Personally, I doubt if it's possible to deactivate some WP core features by plugins or threme...

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Personally, I doubt if it's possible to deactivate some WP core features by plugins or threme

    Oh... it's possible!

    Did you try resetting the plugins folder? Or increasing the available memory?

  5. arturmak
    Member
    Posted 4 years ago #

    Oh... it's possible!

    If you say so ;)

    Did you try resetting the plugins folder? Or increasing the available memory?

    Already done that... And - of course - nothing changed.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    Check your Screen Options on the Edit Post page in case the Author dropdown is being hidden.

  7. arturmak
    Member
    Posted 4 years ago #

    No, it's not hidden. It's hard for me to describe accurately how it looks so I made a screenshot from my Dashboard:

    http://picasaweb.google.pl/lh/photo/B0eNT0MiXMEiNFZ6nQNVGw?feat=directlink

  8. arturmak
    Member
    Posted 4 years ago #

    Solved. I had to do a complete reinstall of WP 2.9.2 and then - once again - update to 3.0. Now it works fine!

    Anyway, thanks Esmi for your help!

  9. esmi
    Forum Moderator
    Posted 4 years ago #

    Glad to hear that you got it sorted.

  10. Timothy L. Gott
    Member
    Posted 3 years ago #

    I came here looking for an answer to the same problem except I upgraded to WordPress 3.1. I didn't like the uninstall reinstall option so I poked around wordpress again.

    In hopes that this might help someone else I found a "Screen Options" menu in the upper right hand corner that must have gotten reset during the last upgrade. In any case it was a simple matter of putting a checkbox in the "show authors" area.

    Take note however that you will need to select "Screen Options" when you are creating or editing a post because the options for that changes depending on where you are in the Admin area.

Topic Closed

This topic has been closed to new replies.

About this Topic