Support » How-To and Troubleshooting » Can’t approve comment sometimes

Can’t approve comment sometimes

  • There are 3 comments that I can’t approve, but I can approve some comments after these 3. Every time I try to approve it from Edit Comments section, it disappear for a while and come back with red background, and there’s a message on the bottom says “An unidentified error has occurred.”.

    I’m using WordPress 2.7, and already try to switch back to default theme (as suggested in several posts) with no luck.

    Any solutions will be appreciated.

Viewing 14 replies - 1 through 14 (of 14 total)
  • I have the same issue….

    I have a similar issue, except no error message is displayed. The comment appears approved, but when I reload the page is back to its original state.

    Hi! I am having lots of problems with every comment that we have now in our blog. i had to approve them in the database through SQL directly. Its really crazy this BUG we are having – http://5dias.net .
    Until now we couldn’t find any solution. We can eliminate, send to spam but not approve them.

    we really need a solution to our problem. comment here if the developers want us/me to test some solution/patch on it.


    I’m having the same problem as raghos – I click ‘Approve’ on pending comments, and it looks like it’s approved. But when I leave and come back, it’s switched back to pending.

    (The workaround I’ve found is to Edit the comment rather than clicking Approve, and then change the status to Approved on the Edit Comment screen.)

    Also – when I log out of WordPress and then go to my blog anonymously to try and post a comment, it hangs, even though the comment is accepted into WordPress. This happens with or without comment moderation turned on.

    Also – I receive no email notification when new comments are posted.

    Oddly, this only started happening today, even though I upgraded to 2.7 a few days ago, and have had comments come in between then and today with no problems.

    Thank you gregclow that trick did it, at list temporarily until we have some other bugfix.
    so we did as you said: “The workaround I’ve found is to Edit the comment rather than clicking Approve, and then change the status to Approved on the Edit Comment screen.)” and it worked, thanks!



    Thanks for the fix gregclow! It’s a brilliant workaround, I should have thought about that! 😀 I just realised today that for comments placed in the pending queue for the same post, some can be approved just by clicking the green ‘Approve’ link while some needs to be edited (or they’ll get stuck in the Pending list forever). This is weird.

    Any official fix for this bug?

    I don’t receive e-mail for approval of comments, and I can’t approve they. It happened after I installed the plugin “Role Manager”…

    Any word on a bug fix for this? I am having exactly the same problem as gregclow.

    I couldn’t find any bugs filed on this issue, so I created one.

    i can’t approve my comment. You don’t have permission message appear. How can i fix that problem !!!!

    gregclow thanks for the tip. It works now!

    I just started getting this after my upgrade to 2.8. Gregclow’s answer works though.

    buddies I found fix, but its not a permanent one.
    Edit the comment in question, then select “Approved” from the status menu.. and its approved> Obviously its not a final solution, but its a temporary one!

    I just started having this problem too. My site was offline for awhile and I recently upgraded to 2.8.4. Has anyone figured out a permanent fix?

    I saw that this was “fixed” going from 2.7 to 2.8 but can we get some info as to what was fixed? https://core.trac.wordpress.org/ticket/9261

    I can’t think of any plugins that may be causing this, so any tip would be great.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can’t approve comment sometimes’ is closed to new replies.