Support » Fixing WordPress » Can’t adjust media file size since upgrading to 2.7

  • Hello,
    Ever since upgrading to WordPress 2.7, I am having an issue where I cannot select the “size” of the image I want to insert when uploading through the browser.

    Screen shot here:
    http://amitai.net/blog/wp-content/uploads/picture-1.png

    I manage two wordpress 2.7 sites. One of them is not having this issue — I uploaded the same picture and was able to resize to “medium”. In the screen shot above, as you can see, I cannot select any of the resize buttons, and the full image is shown as “0x0”. I can insert the full image just fine.

    Image uploading and resizing was not a problem when the site was on 2.6.x.

    I imagine this is some sort of directory permissions issue… help please!

Viewing 15 replies - 1 through 15 (of 20 total)
  • Same here, except my “Full” shows the correct size. Double-checked the permissions on the directory (this is a local install on a mac os x machine), and can’t select any other size but “full.” I can, however, insert the full size version into the post.

    Hey, same problem! I’ve made a clean local installation and there is no possibility to adjust media size. File permissions seems correct. No related errors in apache error_log. “Full” shows the correct size. I could insert image into post and adjust size manually, but it’s boring…

    OS: Fedora 10
    apache: 2.2.10
    php: 5.2.6
    mysql: 5.0.67

    Any update on this?

    In my case it was a plugin conflict (PodPress). Disable the plugins and try to isolate it.

    http://wordpress.org/support/topic/228488

    I have a fresh install upgraded from 2.5 to 2.7, with ZERO plugins installed or activated…and I have this same problem as the OP.

    My media loader looks exactly the same, with greyed-out thumb/medium/large radio buttons. My original size loader works fine, but for my admins they don’t want to do any photoshopping, and the older versions of WP would allow just what we need.

    Anyone have any ideas?

    Hi am having the very same problem on my 2.7 install has anyone been able to fix it ?

    thnx

    Hi chk if GD library is installed and configured properly and also media settings have to be set in admin options atleast this two small things solved the problem for me 🙂

    megaperls — yeah, once disabling podPress, image resize worked.

    I have 3 blogs on my own server running Windows server 2003, WordPress 2.7 and PHP5. 1 blog has problem with not to be able to select image size, only full size, the other 2 options are grey.

    On the 2 other blogs, with the same WP files, just copied from the first, everyting works as it should.

    Anyone any idea?

    Exact same problem, with the exact same conditions. This is crazy! Is it possible to downgrade? I am regretting going to 2.7 now!

    I’m having the same problem, anyone got a solution? I also do not have the podpress plugin and a brand new fresh install.

    I got the same problemem.

    Few months ago, I tested podpress. But is deactived and also deleted for many weeks now…

    I got exactly the same problem running Worpress 2.7.1. And I am not running he podpress plugin.

    The image sizing radio Buttons are greyed out…. please help!

    fritzdsouza was correct. I also had to install the php-gd library which is used by WordPress to resize the images. Tested on 2.7.1

    If you have access, on CentOS or RedHat you can run:

    yum install php-gd

    *Note: There was also mention of ImageMagick needing to be installed, but that did not solve the problem.

    I’m running WordPress locally on 2 machines (one XP, one Vista) while I learn how to create WP themes. The image resizing thing was driving me nuts too, but the other guys are right, it’s the php-gd library.

    I searched for gd in my php.ini file and found

    ;extension=php_gd2.dll

    i took out the semi-colon

    extension=php_gd2.dll

    restarted apache et voila! the image sizes work on upload and are no longer greyed out. however, images i inserted into my gallery before this time still only have the original size available.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Can’t adjust media file size since upgrading to 2.7’ is closed to new replies.