Support » Fixing WordPress » Can't add www to the domain: too many redirects

  • Hi all,

    I installed WP 3.9.1 a while ago, using “domainname.com” as the domainname, so without “www”. Everything works fine, however, I would like to use the domain WITH “www”.

    I tried to change this in the regular options, but when I do, the site can’t be found and an error is returned. Foutcode: ERR_TOO_MANY_REDIRECTS. To solve this I had to login into the MySQL database and change ‘wp-options’ to get the site working again.

    I also tried to change the htaccess with the same error.

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    The clients really wants to solve this, because the old site is using all pages with “www”.

    Other things I found using Google:
    – Change wp-admin permissions to 644 instead of 755, this results in blank pages.
    – Add these to wp-config, this results in the same error:

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Anyone ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Accountteam

    (@accountteam)

    I also tried to change rewriterules from post to id, but no effect either. DNS settings seem fine as well.

    Thread Starter Accountteam

    (@accountteam)

    Sorry can’t edit the posts anymore. I also tried disabling all plugins, also no effect.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't add www to the domain: too many redirects’ is closed to new replies.