WordPress.org

Support

Support » How-To and Troubleshooting » Can’t add widgets to sidebar

Can’t add widgets to sidebar

  • Hello,

    I’m new to coding and all that and recently downloaded WordPress 2.9. I never had a problem adding widgets to the sidebar but recently when I drag and drop I get the error message:

    Fatal error: Call to undefined function wp_redirect() in /home/theweddi/public_html/wp-admin/admin.php on line 33

    Line 33 in admin.php reads:

    wp_redirect(admin_url(‘upgrade.php?_wp_http_referer=’ . urlencode(stripslashes($_SERVER[‘REQUEST_URI’]))));

    Does anyone have any idea what the problem could be? Any help would be hugely appreciated. I’ve searched online all day and can’t find any solution.

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    Hi,

    Yes I removed all the plugins and even deleted them and re-downloaded and installed them.

    I just tried switching to the default theme but the same error appeared. I also re-uploaded the ‘wp-admin’ and ‘wp-includes’ folders, thinking it might be something I changed by accident. Still I can’t add any widgets..

    Thanks for your suggestions.

    Got the very same problem, after upgrading to wordpress 2.9… 🙁 this is very bad

    Yes, I have the same error message also after upgrading to wordpress 2.9. Any help here much appreciated as this affects a number of my sites now

    It seems latest google xml generator plugin and flexi pages plugin is having issues w/ the current version.

    I revert to the previous version of the two plugins and I got it working again.

    Hope to know what’s the issues with this two plugins. I know it’s because wp_redirect() function. I guess I won’t have to upgrade this two plugins till wp 2.9 resolves this.

    Hope this will help you guys.

    I’m trying to add the ‘Add-to-Any Subscibe‘ plugin:
    and the ‘Global Translator‘ plugin:

    I just tried reverting to older versions of each of them but am still getting the same error message.

    Hi,

    IN addition to esmi’s response check with these options;

    – upgrade your wordpress version to the latest stable version
    – remove all the unwanted code from htaccess
    – assign 755 recursive permissions to wp-content folder.

    Thanks,

    Shane G.

    This problem is addressed in the thread “How to fix 3 bugs in WP 2.9”

    Its a wp 2.9 problem…

    I tried using the patch given in “How to fix 3 bugs in WP 2.9” but it didn;t change anything for me. The site is still functioning I’m just not able to add widgets, so I think I might just wait until the next upgrade and hopefully that will sort things out..

    Thanks for all your suggestions everyone! Very much appreciated.

    spero di essere nel posto giusto.

    Ho aggiornato il mio wordpress conla versione 2.9 e non riesco più a visualizzare le sidebar 1 e 2 a destra della mia homepage, mentre nelle altre pagine vedo le sidebar e i windget inseriti.
    Avevo messo pure un simpatico orologio, ma non si vede più nulla oltre che una brutta colonna vuota senza sidebar.

    Cosa è cambiato?

    Might be this related to SlideShow Gallery plug-in?
    See this link: http://wordpress.org/support/topic/344414

    It could’ve been the Slideshow Gallery plugin.
    A new version (1.0.5) has been released with a fix.

    http://wordpress.org/extend/plugins/slideshow-gallery/

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Can’t add widgets to sidebar’ is closed to new replies.
Skip to toolbar