Support » Plugin: Authors List » Can’t add website URL

  • Resolved Ronald Heijnes

    (@dolomite)


    Is it possible to add the url to the website of the author? I have tried this:after_title=”{al:user_url}”. It doesn’t work.
    This is the complete shortcode I am testing: [authors_list after_title=”{al:user_url}” post_types=”post” style=”1″ columns=”3″ show_avatar=”no” show_count=”yes” show_bio=”no” orderby=”display_name” order=”asc”]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @dolomite

    WordPress doesn’t include the website URL as part of the get_user_meta function. We’ll make some changes and release an update tomorrow, it will be possible to show the website URL.

    Thread Starter Ronald Heijnes

    (@dolomite)

    Ah, didn’t know that. But thanks for making it possible! I love your plugin. You can see it in action right here: https://www.worldofwp.com/featured-feeds/

    Plugin Author WPKube

    (@wpkube)

    Hi @dolomite

    Just released the update.

    You’re welcome and thank you, happy to hear that.

    If you can, please consider rating the plugin, will definitely help out the plugin. With more ratings and more users we can spend more time on improving it. Thank you.

    Thread Starter Ronald Heijnes

    (@dolomite)

    The url now shows, but is not clickable. Any advice on how to do that?

    Plugin Author WPKube

    (@wpkube)

    Hi @dolomite

    It just outputs the option value, need to wrap it in anchor tags for a link.

    after_title='<a href="{al:user_url}"> {al:user_url}</a>'

    Make sure that you use the single quote (‘) for the shortcode attribute and a double quote (“) for the anchor attribute. Otherwise they’d conflict with each other.

    And keep that single blank space before the second {al:user_url}

    Thread Starter Ronald Heijnes

    (@dolomite)

    Yes, that’s it! Thank you very much!

    Plugin Author WPKube

    (@wpkube)

    You’re welcome @dolomite

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t add website URL’ is closed to new replies.