WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Can't add users

[Resolved] Can't add users

  • This plugin would solve so many issues for us, but I can’t actually add any users to a section group. I changed their role to “section editor,” but when I enter the email address and click “add,” nothing happens except the little circle keeps spinning. We’re authenticating users with LDAP, but not sure that would make a difference? Any tips appreciated!

    https://wordpress.org/plugins/bu-section-editing/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author BU Web Team

    @bostonu

    You’re trying to add section editors through the “Edit Section Group > Members” tab, correct?

    We’re unable to reproduce this behavior in a fresh WP 3.9.1 install. Could you provide more detail as to your setup? Browser, other active plugins, etc. Are there any Javascript errors showing up in your console?

    We were able to fix the problem. It was giving the error in the console: “Uncaught ReferenceError: buse_site_users is not defined”.

    This line of code below in the admin.groups.php file not loading that caused the issue:
    wp_enqueue_script( ‘buse-site-users’, admin_url( ‘admin-ajax.php?action=buse_site_users_script’ ), array(), null );

    So we added some codes after that to fix it:
    wp_localize_script( ‘group-editor’, ‘buse_site_users’, $current_site_all_users);

    Plugin Author BU Web Team

    @bostonu

    That doesn’t sound right — you shouldn’t have to modify the plugin code to get it to work. 🙂

    I was unable to reproduce in 3.9.1 (or any WP version for that matter) so I’m wondering if perhaps it is browser specific or maybe there is a conflict with another plugin you’re running. Was this issue limited to a specific browser / OS?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Can't add users’ is closed to new replies.