Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Can’t add User Roles into Registration Dropdown

  • Resolved joncon62

    (@joncon62)


    I am trying to add a dropdown for user roles in the Registration form. I’m using the built-in Roles (Dropdown) field and can successfuly add a Subscriber to the list but it is ignoring any other roles I add to the Edit Choices box.

    I am trying to add the following:

    Customer
    Shop manager

    The roles show up in the UM User roles screen. Am I doing this wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • @joncon62

    Use “shop_manager” for “Shop manager” in your list.
    Use “customer” for “Customer” etc.

    You can see the ID’s for all roles in UM -> User Roles

    Thread Starter joncon62

    (@joncon62)

    I tried that already but it didn’t work. Also if I enter ‘subscriber’ with a lower case ‘s’ it doesn’t work but ‘Subscriber’ with an upper ‘S’ does work.

    @joncon62

    Do you use Ctrl-Click on each user role you want to select in the list?

    Thread Starter joncon62

    (@joncon62)

    I don’t see any roles in the list on the Registration page apart from Subscriber, that’s the problem. I can’t seem to add any other role to the default registration form.

    I have tried adding ‘customer’ and ‘Customer’ to the form, using one line for each role, but nothing shows up on the registration page.

    Subscriber
    subscriber
    Customer
    customer

    Shows ‘Subscriber’ as the only selectable role in the registration page.

    subscriber
    customer
    Customer

    Shows ‘No results found’ in the registration page.

    What am I doing wrong?

    • This reply was modified 4 months, 2 weeks ago by joncon62.

    @joncon62

    Have you made the registration form role-specific?

    All documentation about User Roles:

    https://docs.ultimatemember.com/article/1590-how-to-use-user-roles

    Thread Starter joncon62

    (@joncon62)

    The Registration form Customisation is set to ‘No’ so no custom settings
    WP->settings->General has New User Default Role as Shop manager
    UM->settings->Appearance->Registration Form default role is Shop manager

    When a new user signs up they are correctly assigned ‘Shop manager’ role.

    I am trying to add a role selector in the registration form so they can select between Shop manager and Customer but I can’t get it to display anything except Subscriber.

    I have tried the default theme in case there is a conflict but it didn’t work.

    It may be a plugin conflict.

    Can you try it out and see if you can add multiple roles? If it works for you then I’ll try and find the conflicting plugin.

    @joncon62

    https://wordpress.org/support/topic/ultimate-member-user-role-select-does-not-work/

    For security reasons the role fields are limited to UM custom roles only. Go to Ultimate Member->User Roles, inside your dashboard & check if the roles you are mentioning UM custom role or not. If not, they won’t show up.

    • This reply was modified 4 months, 2 weeks ago by missveronica.
    Thread Starter joncon62

    (@joncon62)

    Ah, it doesn’t work the way I thought it did! I have lots of user roles listed in UM->User Roles, but none of them are UM Custom roles which is why I guess none of them show up in the role selection.

    So when I create new Customer and Shop manager roles within UM does selecting “Can view other member profiles?” and “Can view these user roles only” copy over all the original permissions for the selected role?

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @joncon62

    When you create a new UM role, you will need to configure the settings manually.

    Regards,

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hey there!

    This thread has been inactive for a while so we’re going to go ahead and mark it Resolved.

    Please feel free to re-open this thread by changing the Topic Status to ‘Not Resolved’ if any other questions come up and we’d be happy to help. 🙂

    Regards,

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.