Support » Plugin: WP Store Locator » Can’t add starting location

  • Downloaded, installed, and activated plugin. I saw the notification to enter starting location, so I went to the settings menu and found where to enter the starting location values as soon as I clicked the box an error Oops cannot enter location was kind of visible by several grey half circles. I saw were I needed google API’s and followed the poor instructions (not really the plugin authors fault because Google likes to change things every month) to create the server and browser keys. I tried entering the starting location again and received the same error. I cleared cache and other things just to be sure. This was all on WP 4.8.3, so I then tried it with 4.9 and neither version worked for me. I looked on the support forum, but could not find anything that help. To bad because it looks like a good plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Tijmen Smit

    (@tijmensmit)

    You give a one star rating because a third party key causes an issue? Mind blown!

    Did you notice the troubleshooting section on the page that explains how to solve the issue you’re having?

    If you followed the exact instructions on the page that explain how to create the key it WILL work.

    You likely forgot to set the referrer for the created API keys, which is mentioned in the article.

    Dude, your reply is extremely rude.

    You open with enmity over the rating.
    Then proceed to belittle the user.
    Did you notice the troubleshooting section?
    If you followed instructions it WILL work.
    You likely forgot x.

    Dude, get someone to help you respond on these support issues.
    There is no need for all this negative undertone. Seriously!

    Plugin Author Tijmen Smit

    (@tijmensmit)

    @strijdhaftig

    I guess I had a bad day and should have used different words, but that doesn’t change the problem I have with 1 star reviews like this.

    Don’t see how me getting more people to help with support solves issues with people who don’t bother to contact support?

    You download something -> doesn’t work for whatever reason -> don’t bother to read the documentation, don’t contact support -> 1 star rating? It’s a weird logic to me, but guess that’s from the developer perspective.

    It’s a known issue with the keys ( Google requires them, not me ), and also a easy to fix, but you have to read the documentation, or contact support if there’s an issue with them ( 9 out of 10 times users missed a step in creating the keys, resulting in it breaking ).

    • This reply was modified 1 year, 7 months ago by  Tijmen Smit.

    Agreed with the plugin author and fully understand his frustration. It’s unfortunate the user didn’t read the documentation and chose instead to leave a 1-star review. Plugin authors devote many hours into development and deserve apt diligence from users. The user should delete this review. Poor form. Excellent plugin!

    • This reply was modified 1 year, 1 month ago by  mattrock1.
    • This reply was modified 1 year, 1 month ago by  mattrock1.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t add starting location’ is closed to new replies.