Support » Plugins and Hacks » Code Snippets » [Resolved] Cant add snippet

[Resolved] Cant add snippet

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Shea Bunge


    Strange… so you enter your code and a name for the snippet, save the snippet, and nothing appears on the manage snippets page? If so, can you tell me if a wp_snippets table exists in your WordPress database and, if so, is it empty or not?

    i have the same problem (Multisite Version 3.5.1 PHP 5.54 Mysql 5.5.28)

    1. i try Import from snippets:
    “you have added 9 snippets”
    but nothing appears on the manage snippets page

    I try to add snippets direct:
    “Codes Snippets activate”
    but nothing appears on the manage snippets page

    I found no wp_snippets table in my WordPress database
    I delete/install and activate the plugin a few Times – still no snippets table in Database


    I have the same problem i tried to add 3 snippets but nothing saves to the manage snippets page, After adding snippet and short title when you click save and activate or just save it just goes back to the add snippet again like you never even added anything.

    Also here a (probably the same as above) problem with WPMU:

    After submitting a well filled in form for a new snippet the form fields are emptied and a message is given:

    Please provide a name for the snippet and its code

    UPDATE: I did a fresh WPMU install with no other plugins activated and tried to network activate the plugin.
    Gives this warning 4 times:

    Warning: in_array() expects parameter 2 to be array, boolean given in W:\bootje\wp-content\plugins\code-snippets\code-snippets.php on line 543

    Hi Shea, thanks for making this plugin. Unfortunately I’m also having the same problem as the others here on a multisite install.

    I am able to activate the plugin on the main site or by network activating it. However when I try to add a snippet I get this error:

    Please provide a name for the snippet and its code. 

    It would be great if you can solve this when you have the time. Thanks!

    Hi Shea- I am having the same issue in my multisite install that the others are reporting. (Both when network activated, and per site activated) It is working just fine in my regular single site installs so it appears to be a multisite issue? I am using a sub domain setup for my sub sites.

    I tested activating per site as well, and when I log in as the sub-site admin, I am able to activate the plugin, but when I try to manage, I see, “You do not have sufficient permissions to access this page.” When I am logged in as super admin and go to that same sub site, I can activate the plugin and manage, but when I add a snippet, it doesn’t save, and I get the following “Please provide a name for the snippet and its code” (the same message that I get when I have it network activated.)

    can you tell me if a wp_snippets table exists in your WordPress database and, if so, is it empty or not

    I do not see a wp-snippets table in my database.

    Thanks for this great plugin. It would be handy to use on my multisite as well. 🙂

    I am having the same issues on multisite as Jennifer Ross mentions.
    Author should have tested it and should have mentioned on the introduction page that the plugin doesn’t work on multisite configurations. Now lots of people are getting frustrated and loose a lot of developing time because they don’t understand the non function and try to figure it out.

    Same problem here on a brand new WP v3.5.2, Genesis 2.0 beta 2, network install. No matter what kind of snippet, title or description ~ on hitting SAVE it just comes back with “Please provide a name for the snippet and its code.”

    Well, the author is on a LONG vacation I think.
    On the other hand: Is this plugin THAT important?
    Pros: it’s easy. (And I like the idea)
    Cons: you make yourself dependent on author’s mood to develop or not, probably less rendering performance because of (perhaps many) database accesses.

    Plugin Author Shea Bunge


    No, I’m not on vacation, still here answering support threads 🙂

    I’m just really busy at the moment, but I’m still working on the next version of Code Snippets, which will, among other things, remove the restriction of needing a name and code for a snippet at all.

    If you’re interested in how the development’s going, check out the GitHub repo.

    Hi Shea, thanks for your reply.
    Just to be sure: do you test the new version(s) also for multisite configurations?

    I just checked out the current version on a standard install and it works fine. Its just the network version it seems to be having problems with.

    Plugin Author Shea Bunge


    @violacase yes, I actually run Code Snippets on my personal multisite network, and my primary dev environment is also a multisite network.

    The plugin should be released soon; I just want to make sure that it’s ready and fixes all known bugs before I ship it.

    Great Shea!
    As said before: I really like your concept.
    Remains one important question: could you also do some performance tests? I don’t know if a sequence of database calls will significantly slow down the rendering process. Perhaps it maybe even faster then the traditional one time file (functions.php) access?

    Plugin Author Shea Bunge


    Hmm… not sure why last message posted twice, but anyway.

    I think I may have narrowed down the saving issue to the Code Snippets Tags plugin. Can I confirm if you are all using this plugin or not?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] Cant add snippet’ is closed to new replies.
Skip to toolbar