Support » Plugin: WooCommerce » Can't add products to cart

Viewing 15 replies - 1 through 15 (of 44 total)
  • Roy Ho

    (@splashingpixelscom)

    Double check you have added a price for the variations, not the product itself. You will see a faint message telling you that “price is required” in the price field of the variations. Without setting it, in the frontend you will only see the dropdown to select an option and nothing else.

    I tried adding prices to each variation, still no luck.

    http://www.coreytegeler.com/bolivares/shop/cruz-hand-knit-long-alpaca-scarf/

    Here’s were I’m testing it.

    Roy Ho

    (@splashingpixelscom)

    Well for you, you have JS errors on your site…correct that first.

    How exactly can I get go about finding what errors I have?

    Roy Ho

    (@splashingpixelscom)

    Sorry I can’t help you there…But if you look at your console with any dev tool, it will tell you what errors your site is seeing.

    Could you suggest a good dev tool to use?

    Roy Ho

    (@splashingpixelscom)

    You can use either firebug for firefox or the built in chrome tools for chrome.

    There is a very high possibility that one of the existing plugin on your site is conflicting. Disable all plugins except woocommerce and then try.

    I’ve tried disabling all plug-ins and all JS libraries, same issue always occurs.

    Also, at one point every product worked, not sure what I could have done to mess this up 🙁

    The problem is in your theme, not the plugins, specifically that it isn’t loading the jQuery plugin “mobileMenu”. In chrome the error is being reported on line 8 of /wp-content/themes/max-magazine/js/custom.js:

    Uncaught TypeError: Object [object Object] has no method 'mobileMenu'

    jQuery('#nav .menu').mobileMenu({
        defaultText: 'Navigate to...',
        className: 'select-menu',
        subMenuDash: '   –'
    });

    Comment this out and (assuming there aren’t further errors) you should see the add to cart button.

    Thanks! I just checked it out and realized there is nothing I even need in the custom.js file so I just deleted it and the script that was looking for it in the header so there are no more errors, yet I still get my original problem.

    Any word on this?

    Roy Ho

    (@splashingpixelscom)

    Have you check if it isn’t your theme issue? Switch to 2012 theme and see.

    Just tried it, same issue

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Can't add products to cart’ is closed to new replies.