Support » How-To and Troubleshooting » [Resolved] Can't add plugins!!

[Resolved] Can't add plugins!!

  • I can’t seem to add plugins to my newly installed wordpress blog! I recently bought a domain from dreamhost.
    My blog’s admin page doesn’t even give me the option of adding plugins!

    Help please!

Viewing 15 replies - 1 through 15 (of 33 total)
  • Moderator James Huff


    Do you have a hosting account with WordPress installed at Dreamhost, or did you buy a domain from Dreamhost for use with a wordpress.com blog?

    Hi James!

    I bought the domain on Dreamhost, and then I used the one click install to install wordpress.

    My site is: blog.joshuasunga.com

    Please help!

    Moderator James Huff


    Just go to Plugins/Add New in your admin panel. If you don’t see that option, please share a screenshot of your admin panel’s sidebar so we can see what you do have.

    It doesn’t have the “add new” option for plugins, just the akismet configuration!

    Moderator James Huff


    That’s quite strange indeed.

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the the Twenty Ten theme to rule-out a theme-specific issue (theme functions can sometimes interfere with the admin panel).

    Hi James

    Thanks for the help! Unfortunately, neither suggestion has worked 🙁

    I deactivated all plugins – nothing happened!

    Twenty Ten theme – I’m already using the Twenty Ten theme, but I switched to other themes and nothing happened to the admin panel – i still don’t have the option of adding plugins!

    if its worth anything: i’m halfway thru a free trial on dreamhost – but i don’t understand why that’s an issue because i’m gonna start paying for hosting after next week!

    What should I do?

    Moderator James Huff


    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download.

    Hi guys,

    I’ve downloaded WP 3.0.1 few days ago and face the same problem than joshuasunga, i.e.
    a) I don’t have the option ‘add new’ plugin.
    b) If I try to install the ‘Plugin Browser/Installer functionality’, I receive the following message: “You do not have sufficient permissions to install plugins on this site.”
    c) Nothing happens when I upload plugins through my FTP (FileZilla).

    I’ve tried changing themes, deactivating/activating the plugins offered in with the WP 3.0.1, and nothing changes, I simply can’t add new plugins…

    Any solution then? Did reinstalling WP worked for you joshuasunga?

    I hope forward to receiving any further advice.



    Moderator James Huff


    It’s possible that your account lost admin privileges for some reason.

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}

    James, thanks a lot for your help.

    I just went to the phpMyAdmin but couldn’t find any wp_users table or wp_usermeta table (only information_schema and the database I created ie makingsenseofthings_db)… Please note that I’m a beginner in blogging so I might have missed a step somewhere… Any further indication then?

    Thanks indeed,


    Moderator James Huff


    The tables will be inside the WordPress database.

    Hi guys

    Sorry for not replying – i’ve been caught up in other things the last few days! :s

    i’m very limited in my computer/coding knowledge. i’m gonna try deleting and re-installing wordpress.

    jscrg – sorry i can’t be of much help to you! question: are you on dreamhost too?

    Then I must definitely have done something wrong. The answer I get is “No tables found in database.”… Which step did I miss?

    No worries joshuasunga, we are definitely learning by doing!…

    Thanks James,


    Moderator James Huff


    If you didn’t have tables, you wouldn’t have a blog either. Are you sure you’re accessing the same database that you assigned to WordPress in the wp-config.php file?

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Can't add plugins!!’ is closed to new replies.