WordPress.org

Support

Support » Plugins and Hacks » Can't add Patrons

Can't add Patrons

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Robert Heller

    @robertpheller

    What operating system is the server running? What version?
    What version of MySQL? What version of PHP?
    What version of WordPress?

    Plugin Author Robert Heller

    @robertpheller

    Also: what are you using for a web browser?

    WordPress 3.5.1
    Mysql 5.6 (I’m not that sure about this actually)
    PHP 5.3.19
    Browser : Chrome

    thanks!

    Plugin Author Robert Heller

    @robertpheller

    Is the server a MS-Windows server or a Linux server?

    What happens if you use Firefox?

    I’m using a MS-Windows server.
    Tried firefox but same thing happened.

    I inserted a patron manually on MySQL. Now I have the patron,
    but seems like my circulation doesn’t work either. When I tried to place hold, it says AJAX Error : Internal Server Error.

    Plugin Author Robert Heller

    @robertpheller

    Are you IIS or Apache?

    The MS-Windows version of MySQL is *different* from the Linux/UNIX version of MySQL. Part of this is a function of the design of MySQL (depending on a case-sensitive file system). The MS-Windows and Linux/UNIX versions of MySQL are not totally compatible with each other. I don’t know what the AJAX error is caused by. Since I don’t have a MS-Windows system to test on, I can’t be of much help. The easy solution would be to install Linux on a spare spare machine or even as a VM on the MS-Windows machine.

    Is there some reason you are using MS-Windows Server? It is certainly an *expensive* option.

    I’m on IIS7. The reason I’m using a Windows server is because it’s what our company have. Hmm… guess that’s the only possible solution. I suspected that.

    Plugin Author Robert Heller

    @robertpheller

    You can try updating to 3.2.9.2 — this fixes some minor bugs and *may* solve your problems.

    Plugin Author Robert Heller

    @robertpheller

    Were you able to solve your problem? Did upgrading 3.2.9.2 fix things?

    With regard to the AJAX error, I receive this error when clicking the “Request” button to put a hold on the book. Specifically, the ajax call returns this:

    <b>Warning</b>: file_put_contents() [<a href=’function.file-put-contents

    To solve, I commented out line 84 of PlaceHoldOnItem.php .

    Similar messages on my PHP log reveal what looks to be a write-permission error to php://stderr (note – I have plenty of disk space)

    [17-Jul-2013 13:45:19 UTC] PHP Warning: file_put_contents() [function.file-put-contents]: Only 0 of 66 bytes written, possibly out of free disk space in C:\inetpub\wwwroot\wp1\wp-content\plugins\weblibrarian\includes\WEBLIB_PatronRecord_Admin.php on line 247

    [17-Jul-2013 14:24:51 UTC] PHP Warning: file_put_contents() [function.file-put-contents]: Only 0 of 132 bytes written, possibly out of free disk space in C:\inetpub\wwwroot\wp1\wp-content\plugins\weblibrarian\PlaceHoldOnItem.php on line 84

    [17-Jul-2013 12:53:12 UTC] PHP Warning: file_put_contents() [function.file-put-contents]: Only 0 of 164 bytes written, possibly out of free disk space in C:\inetpub\wwwroot\wp1\wp-content\plugins\weblibrarian\includes\short_codes.php on line 195

    Plugin Author Robert Heller

    @robertpheller

    Argg! MS-Windows is *obviously* not a POSIX operating system. I’m guessing mess-windows does not bind stderr to anything — ALL POSIX/UNIX/Linux systems bind stderr to something, typically on a LAMP server this would be Apache’s errro_log. I’m guess IIS does not have an error log or else php under IIS does not bind stderr to anything. Dumb. How do they expect people to debug code? Or log errors?

    Logging does occur. The log file where I copied those errors from is specified in the php.ini file.

    As for the standard error stream, Microsoft states that:

    Internet Information Services (IIS) FastCGI module will fail the request when PHP sends any data on stderr by using FastCGI protocol.

    http://www.iis.net/learn/application-frameworks/install-and-configure-php-on-iis/secure-php-with-configuration-settings

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can't add Patrons’ is closed to new replies.