Support » Plugin: Code Snippets » Can’t add or Edit Existing Code Snippets

  • Resolved rseitzberg

    (@rseitzberg)


    I tried to add a code snippet and it would not add any snippets. I tried adding multiple times but it would not show in the wordpress admin or work. I then deleted code snippets and re-installed and then all of the code snippets I tried to add showed up in the snippet list. I was unable to edit the snippets though. So I tried deleting the whole folder with SFTP and re-install, same problem. The old snippets were visible but I could not edit them. I could open them, make changes, but the changes would not save.

    I then de-activated all plugins and tried to add or edit snippets and I had the same problem. I am unable to add or edit snippets. I use code snippets for almost all of my sites and this is the first time I have had an issue using it. I am just trying to add the google maps api to ACF withough having to update the functions.php but I am unable to do so. Can you check to see that there isn’t a problem in the newest update?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same here, fresh site and installed code snippets.

    I can add snippets, but they don’t show in the List of snippets..

    I can’t delete the pre-installed snippets either.

    Not sure if its the same issue but im wondering if something broke with recent updates?

    I am having pretty much the same problem, too.

    The plugin just got all glitchy. Can’t edit anything within a plugin–title, code, description…nothing. Hitting the Save button shows the “plugin updated” banner like you successfully did, but everything just shows/reverts back to what was previously there.

    The Snippet list is also glitching. You can toggle an active plugin to inactive, which fortunately does deactivate the plugin, but upon refreshing the page it shows the toggle as active again (plugin is still deactivated, though, as far as I can tell).

    Can’t delete any snippets either.

    Can’t change any settings, either–they all revert back to the setting it was previously at.

    same problem

    Same here since the new update. After a while though the new snippets show up. Edits may or may not save. Fix please!

    I think we have the same problem since the last update to the new version 3.
    New snippets are created but not immediately displayed in the snippets list.
    Snippets are edited but changes are not immediately displayed.
    We have found that disabling WP object cache (Redis) temporarily solve the problem.

    Plugin Author Shea Bunge

    (@bungeshea)

    I’ve been looking into this, and I am pretty sure it has to do with how object caching is implemented. I can’t be sure, but I’d be willing to bet that anyone who is affected has some sort of persistent caching installed.

    I’m working on a new version now which hopefully should resolve these issues.

    I may have some caching things happening but I should also have /wp-admin/ excluded from it.

    Thank you for fixing on your end to make it easier for us!

    I have reproduced this on three WP Engine Shared hosting sites with v3.0.x. I tried on a WP Engine site on a private server and it did not reproduce there. All I have to do to reproduce is to be on a shared WP Engine environment with object caching (and all their other environment caching) enabled and edit a snippet and save and it will revert to the previous code. Clearing caches may have resolved one time but problem returned.

    Plugin Author Shea Bunge

    (@bungeshea)

    Just released v3.1.0 which should resolve this problem.

    This problem seems to be solved now.
    Thanks for your work on this great plugin.

    Working great now. Thanks @bungeshea.

    Plugin Author Shea Bunge

    (@bungeshea)

    Glad to hear it! Thanks for confirming for me.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.