Support » Fixing WordPress » Can't add or delete users

  • This problem started even before the latest update to WordPress 4.6. I can manage users, meaning I can change their roles but I can’t add or delete them.
    Luckily dreamhost have support (unlike WordPress) and they guided me a lot and gave me lots of tips but unfortunately nothing works. I think I’ve tried everything already (deactivating plugins, deleting old files, upgrading to the latest versions of everything, etc.)

    This is a problem that Dreamhost found:
    There may be an issue with your user_roles option_value in the database which is causing the weird admin problems.
    There’s fun/funky/likely-non-English characters in the database in the user_roles option_value.

    I wrote to Zerif Pro (where the problem is but which I no longer use) and they assured me that their theme couldn’t possibly make any changes to the database.

    Please, help! What can I do?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    (@t-p)

    Luckily dreamhost have support (unlike WordPress)

    You pay to use dreamhost!

    You don’t pay to use WordPress.

    WordPress is free software and this free, volunteer-staffed forum is the only support resource available via wordpress.org. If you would prefer a one-to-one discussion, please try:
    http://directory.codepoet.com/
    or
    http://jobs.wordpress.net/

    I wrote to Zerif Pro

    These forums are for free themes available in the WordPress theme directory at wordpress.org/themes/. So please contact the developer/vendor directly for support with your question. You’ll be more likely to find a good answer from them, for they have the access to its code. Forum volunteers are not given access to commercial/custom products, so they would not know why your /custom/commercial theme or plugin is not working properly. The developers/vendors are responsible for supporting their custom/commercial product. See http://codex.wordpress.org/Forum_Welcome#Commercial_Products

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Speaking as a DreamHost employee… You pay for hosting, you don’t (generally) pay for WP support from your webhost.

    Anyway.

    This is a problem that Dreamhost found:

    There may be an issue with your user_roles option_value in the database which is causing the weird admin problems.
    There’s fun/funky/likely-non-English characters in the database in the user_roles option_value.

    Check your wp-config.php and see what the DB_CHARSET is set to. You MAY need to comment that out, however I’ve not seen that as a problem at DH since we upgraded everyone to MySQL 5.5+

    Fixing the user_roles options is a pain because there really isn’t a great way to fix it.

    It should be named PREFIX_user_roles, so if your DB Prefix is wp1234_ then it would be wp1234_user_roles and the default value looks like this:

    a:5:{s:13:"administrator";a:2:{s:4:"name";s:13:"Administrator";s:12:"capabilities";a:61:{s:13:"switch_themes";b:1;s:11:"edit_themes";b:1;s:16:"activate_plugins";b:1;s:12:"edit_plugins";b:1;s:10:"edit_users";b:1;s:10:"edit_files";b:1;s:14:"manage_options";b:1;s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:6:"import";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:8:"level_10";b:1;s:7:"level_9";b:1;s:7:"level_8";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:12:"delete_users";b:1;s:12:"create_users";b:1;s:17:"unfiltered_upload";b:1;s:14:"edit_dashboard";b:1;s:14:"update_plugins";b:1;s:14:"delete_plugins";b:1;s:15:"install_plugins";b:1;s:13:"update_themes";b:1;s:14:"install_themes";b:1;s:11:"update_core";b:1;s:10:"list_users";b:1;s:12:"remove_users";b:1;s:13:"promote_users";b:1;s:18:"edit_theme_options";b:1;s:13:"delete_themes";b:1;s:6:"export";b:1;}}s:6:"editor";a:2:{s:4:"name";s:6:"Editor";s:12:"capabilities";a:34:{s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;}}s:6:"author";a:2:{s:4:"name";s:6:"Author";s:12:"capabilities";a:10:{s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:4:"read";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;s:22:"delete_published_posts";b:1;}}s:11:"contributor";a:2:{s:4:"name";s:11:"Contributor";s:12:"capabilities";a:5:{s:10:"edit_posts";b:1;s:4:"read";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;}}s:10:"subscriber";a:2:{s:4:"name";s:10:"Subscriber";s:12:"capabilities";a:2:{s:4:"read";b:1;s:7:"level_0";b:1;}}}

    But I think this would work via command line (which you do have on DreamHost)

    wp role reset --all

    Based on http://wp-cli.org/commands/role/reset/ that may do it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't add or delete users’ is closed to new replies.