Support » Fixing WordPress » Can't add new class and id names to my style sheet / new page template

  • Resolved Karyn Ellis Here


    Hi there!

    Is anyone else having difficulties adding new class and ids to their style sheet after adding Google analytics plug in?

    I’m running into a weird problem here.

    I have been making new page templates for my site without too many issues by simply copying old pages and changing the template name. Then copying the css from the old page and changing relevant names of classes and ids in the style sheet and on the new template. Up until yesterday this was working (clunky as the process may be.)

    But, now for some reason my site is not registering new class and id names. The new template shows up fine, and if I use old class and id descriptors in the new page, everything works groovy. But as soon as I try to add a new one (ie: changing .body-bg-paper-houseconcert to .body-bg-paper-fundraisetheroof in the style sheet then replacing “houseconcert” with “fundraisetheroof” in the template)… the formatting disappears.

    The only thing that is different this time building a new template page is that I recently added The Google Analytics plug in. I am wondering if this is somehow interfering with the creation of new style instructions.

    Btw, I am a newby to coding: mostly cut ‘n pasting what my programmer set up for me since he is no longer available to do updates. Believe it or not, it’s been working out pretty well so far. I have a basic understanding of css to be able to make changes in my style sheet. I think I can wrap my head around php too, though doing any coding is way beyond me. … So I’m not even sure what coding would be helpful for you to see to diagnose the problem.

    But here’s my site: does that help?

    I’m trying to use a template similar to either the home page or the contact page – but without all the blog roll and twitter links and stuff like that. Basically, I want two columns.

    But even when I tried a very simple page template, like
    the problem still persists.

    PS, at first I thought I had made errors when cutting and pasting into a new template, a missing ; or something. But even when I duplicated a template exactly and only changed one thing: a new class name for one section, it didn’t work. And when I reverted to the original cut and pasted template (using a new template name) everything was showing up again fine.

    Sorry this is soooooo long. I don’t know how to describe it any more succinctly (calling on my newby card again!)

    Any thoughts to where I’m going wrong here? Or… has anyone else experienced this weirdness after adding a plugin?

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you remove Google Analytics plug in to see if this issue went away?

    That’s brilliant! Didn’t even think of it. Will try it out and see what happens…

    It worked! Thanks!

    I turned the plugin off, loaded the new style sheet… shift-reloaded the page a couple of times. Voila! The changes stuck. And, I am still able to make changes to the new class & id even though the plug in is back on.

    I guess once the changes made it into the inner workings of the site, they are continuing to be recognized.

    Thanks so much for your suggestion! 🙂

    Glad it worked.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can't add new class and id names to my style sheet / new page template’ is closed to new replies.