Support » Plugin: Polylang » Can’t add multiple language versions i.e. en_GB & en_US

  • Resolved Mike Wiegand

    (@mikeg_de)


    Hi,

    any idea what may cause adding multiple version of a language not to fail? I.e. adding de_DE, de_AT and de_CH fails for the last two. Same goes for en_GB and en_US and so forth.

    Thanks for your support
    Mike

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter Mike Wiegand

    (@mikeg_de)

    Solved … for some reason the error wasn’t shown. The language code must be unique referring to ISO 639-1. Though, this causes a conflict on serving a website from the same language i.e. German in Germany, Austria and Switzerland or English in UK, US or Australia or Spanish …

    Anyway, I had added a suffix like “-ch” for Switzerland but I guess the language recognition won’t work anymore. Would be great to get the limited ISO replaced.

    Cheers
    Mike

    Plugin Author Chouby

    (@chouby)

    Hi!

    The detection of the preferred browser language will still work, because it’s not based on this code.

    Thread Starter Mike Wiegand

    (@mikeg_de)

    Hi @chouby,

    thanks for clarification. I noticed another bug on re-importing content. When having multiple languages installed like in the given example, the link to the corresponding translations gets lost. On re-import categories, slugs etc. are not imported. Polylang says some contents are missing translations and to correct this the default language has to be set for then. in the next step the corresponding translations have to be re-linked.

    To give a more graphical example:
    1. Installed de_DE, de_CH and de_DE (Austria)
    2. Export / Import with failures due to cross over of de_DE but also on some CH content
    3. Setting default de_DE language
    4. Re-Link required

    One notice, though. The languages were installed and configured before import so the environment was setup correctly.

    Kind reagrds
    Mike

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t add multiple language versions i.e. en_GB & en_US’ is closed to new replies.