Support » Plugin: Product Feed PRO for WooCommerce » Can’t add more than one rule

  • Resolved venenifer

    (@venenifer)


    Hi,
    if I add more than one rule, then click save, only the last rule entered will be saved.
    Whenever i go back to my feed settings > filters & rules, i only find one rule in there.

    Any idea how can i fix this?

    thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’ve the same problems, I contacted support 9 days ago, I dont received reply since.

    Plugin Author AdTribes.io Development Team

    (@jorisverwater)

    @venenifer and @ajna667,

    First, my apologies for my late response. I’ve been extremely busy the last couple of weeks as I was working on the Google Shopping EC-verdict and its outcomes. I know it’s not an excuse as you are experiencing problems with our plugin but I hope you understand 🙂

    The good news is that I have just released a new version of the plugin (1.5.3) that solves the bug you are reporting. Just update the plugin and you should be fine again.

    Let me know if it worked out for you.

    All the best,
    Joris

    Thread Starter venenifer

    (@venenifer)

    Hi Joris,
    thanks for your reply. I have updated the plugin but the issue is still there; only the last rule entered is saved.

    Also, in Chrome browser console i noticed this error while visiting every page of my website (frontend):

    GET https://www.mywebsite.com/wp-content/plugins/woo-product-feed-pro/js/woosea_tracking.js?ver=1 404 ()

    Sometimes this error appears twice on every page. Any idea?

    kindly,
    Val

    Plugin Author AdTribes.io Development Team

    (@jorisverwater)

    @venifer,

    Mea culpa, the missing Javascript error is my bad. I fixed it by releasing a new version (1.5.4). Thanks for letting me know this fast!

    Did you try to make a complete new project to fix the rules/filters? I did and can perfectly save multiple rules and filters, see this screenshot:
    https://www.dropbox.com/s/76ywuveslz9gsfh/filters-rules.png?dl=0

    Best,
    Joris

    Thread Starter venenifer

    (@venenifer)

    Hi there!

    I tried deactivating current project and creating a new one, but i still had the same issue. Then i DELETED ALL PROJECTS and created a new one. Voilà! All sorted.

    Also that error has gone after last update.

    Many thanks fro sorting this out, mate!

    I am having same problem. I tried deleting all projects and starting new but it didn’t fix it for me. Only the last filter is saved.

    I need to exclude a number of products and am doing it by using a filter that says:
    If Product ID is equal to 3023,2635,2537,2633,2556,37756 then exclude. Will the comma separator work? I thought it was working at one point but now it seems to only grab the first entry (3023).

    I tried doing one product per row but can’t get multiple filters to save, only the last one.

    Thanks, Karen

    Plugin Author AdTribes.io Development Team

    (@jorisverwater)

    @karen,

    Adding multiple productID’s in just one filter of rule has never worked. You need to create a seperate rule or filter for each productIF.

    – did you update to the latest version of the plug-in?
    – did you create a new project?
    – and clear cache?

    Than all should work.

    Thx
    Joris

    Ok on the no comma separator. I’ve tried more than one plugin so must have been somewhere along that process where it worked.

    Yes, I am updated to latest plugin, deleted all projects, created new projects and flushed cache. We use Varnish cache though and it sometimes messes things up. I will try again on that process.

    Hi Joris – adding multiple filters is resolved for me. After deleting projects, clearing cache on server etc, I found that I also had to clear my browser history.

    I can’t enter more than 8 filters. Is that a cap set in the plugin? We have some products in the vitamin supplement space that Google disapproves so it’s a much cleaner solution to remove them from the feed.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t add more than one rule’ is closed to new replies.