Support » Fixing WordPress » cant add media – error 403

  • Hi all,

    I’m new at wordpress. Really enjoying it so far. I understand html and css. But not php, though I’m getting there. I’m a beginner and I’m currently working on a website.

    So heres the problem. Yesterday when I tried to add new pictures to my site (It has worked fine before), I pressed “Media” and Instead of coming to the normal page I get this:
    Error 403: Forbidden
    Your PHP settings have been disabled by an H-Sphere administrator.

    Your current PHP configuration:
    This configuration was changed: Thu Mar 31 01:00:09 UTC 2011
    Please bring your PHP configuration in compliance with admin settings or request your administrator to re-enable support of your settings.
    What is this and what should I do? Thanks!


Viewing 5 replies - 1 through 5 (of 5 total)
  • Alexandra,

    Make sure you have correct permissions and ownership for /uploads/ folder. If ownership is wrong and you can’t change it, contact hosting support and they will help you.


    does this have anything to do with chmod?

    changed all chmod settings. Still not working. Tried calling my webhoster. No answer.


    Yes, that was about chmod and chown. /uploads/ folder should have 777 permissions (sometimes 775 enough, depends on server configuration). If you have php-cgi with suphp installed, then 755 should be fine and 777 should show 500 error. Make sure you have all files chowened correctly (have correct ownership). Check out your username in control panel. It’s the same as main FTP username. Try to chown your files (if you have SSH and you know how to use it) like this:
    chown -R username:username /path/to/public_html/

    This is strange error message, however, may be there are some tickets already exist for you. Also you may try to restart PHP for your domain from H-Sphere->Domains->Choose your domain name(or if you have only one domain name, you may not need to chose)->Click on the ON image near PHP and then click on the OFF image on the next same page.

    ok. Thanks alot for your involvement. I appreciate it.

    Tried to do everything you said. The things I understood anyway ( I feel like a child playing with fire when I’m in the filehandler, haha). Anyway. I still can’t upload media, but I managed to do something. Something stupid. Now I can’t reinstall wordpress either.

    I get this:

    Warning: touch(): SAFE MODE Restriction in effect. The script whose uid/gid is 132414/132414 is not allowed to access /tmp owned by uid/gid 0/0 in /hsphere/local/home/kamis/ on lin

    What have I done?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘cant add media – error 403’ is closed to new replies.