WordPress.org

Forums

Business Directory Plugin
[resolved] Can't add listings? (18 posts)

  1. johnson6325
    Member
    Posted 2 years ago #

    I did the install on WP 3.5 today and have adjusted most of the settings and added categories. When I go to add a listing from the front end, I get the following error. I believe all my permissions are correct. Any ideas what I may have missed. Everything else appears to work fine.

    Error Message:

    Forbidden

    You don't have permission to access / on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    http://wordpress.org/extend/plugins/business-directory-plugin/

  2. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Hi johnson6325,

    Is this site publicly available? Can I see it?

    From the sounds of it, you may have a permission issue with your .htaccess or files on the server. BD shouldn't be the source of that. Can you confirm that BD is the one causing this issue? Do you get the error doing anything else on your site?

    Have you ruled out a plugin conflict? See this article for more info on it: http://businessdirectoryplugin.com/support-forum/faq/how-to-check-for-plugin-and-theme-conflicts-with-bd/

    One last thought: We've discovered that Jetpack is causing some issues (although this one would be a new symptom) with a lot of plugins since its last update. If you have it enabled, try disabling it.

  3. johnson6325
    Member
    Posted 2 years ago #

    Go to http://ohioshaleconnect.com/?page_id=4 and see what you think. We don't seem to have any other issues. Everything else seems fine. We are just trying to get this working so we can add the listings and style everything out.

  4. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Have you tried the plugin conflict test? Are you running Jetpack as I mentioned above?

    What about my other questions above?

  5. johnson6325
    Member
    Posted 2 years ago #

    I am not running jetpack. I also currently have all other plugins disabled and changed the theme back to default 2011 theme.

    What should the htaccess be set to? I don't seem to have any other issues. I can create posts and pages with out issue.

  6. johnson6325
    Member
    Posted 2 years ago #

    I can add categories just fine, would that not use the same htaccess settings as adding listings? Or does it have to do with the fact adding listings is on the front end while adding categories is on the backend?

  7. johnson6325
    Member
    Posted 2 years ago #

    I just added a listing to accounting in the backend just fine. I just can not do it through the form on the site? I hope that helps

  8. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Hmmm. When I try to add the listing, I don't get the 404 error or any specific error message, it simply redirects me to the main directory page. Something is off, but the symptoms aren't consistent.

    Do you have the slug "business-directory" repeated on any page (in addition to being used in BD)? That would cause odd behavior too. Check all pages, and make sure you don't have any sitting around in the trash either, as they will cause the problem as well.

  9. johnson6325
    Member
    Posted 2 years ago #

    I no longer get the 404 either?? Could that have something to do with the listing I added through the backend?

    I looked through the other pages and posts and businessdirectoy is not listed on any of those pages?

  10. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    And nothing in the trash, either?

  11. johnson6325
    Member
    Posted 2 years ago #

    No trash is clear. I emptied it out.

    I love this plugin and hope to get it working. I removed all the listings and it still did the same thing. I have most of the other plugins still off.

    Any other ideas to try?

  12. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    I guess we need to get admin access to look into it more deeply. Can you send it via the contact form?

    http://businessdirectoryplugin.com/contact/

    Please include a link to this post so we know the context.

  13. johnson6325
    Member
    Posted 2 years ago #

    Sent info through contact form. Thanks

  14. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Got it, thanks. It will be a bit, as we're right on top of the holiday and I need to wait for my developer's return from family time.

  15. johnson6325
    Member
    Posted 2 years ago #

    Thanks, I am trying to have the site ready to go live by Jan. 1. I am hoping you can figure out the issue and I can purchase a couple of the additional products before I go live.

  16. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Looking into it.

  17. johnson6325
    Member
    Posted 2 years ago #

    Thanks, we are waiting to put anymore listings in the directory until it is working.

  18. businessdirectoryplugin
    Member
    Plugin Author

    Posted 2 years ago #

    Hi johnson6325,

    Sorry for the delay, my developer responded but I mixed up the threads and didn't know the response was for you. Here's what he said:


    I don't get a 404 but the same page displays again and I found something odd outside of our plugin's scope: I was trying to diagnose the problem by adding some debugging output to the plugin so I went to the "Plugin Editor" (Plugins - Editor, admin side) to edit some files and when I clicked "Update File" I got a 404 error displayed (user side). This doesn't make any sense and has nothing to do with BD so I think something is off with some forms on this WP setup.

    Trying to remove BD from the equation, I disabled the plugin and tried this again (editing any file through the "Plugin Editor") and got the same 404 error. This means BD is not the problem here.
    I'd love to help the user but since I can't edit files to add debugging messages (because of said 404 error) I can't do anything further. What I can assure you is that it must be another plugin or something at the WordPress/Apache level. Or perhaps a memory/server issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.