WordPress.org

Support

Support » Themes and Templates » [Resolved] Can't add link in post after updating

[Resolved] Can't add link in post after updating

  • I’m using Twenty Ten for a site and after updating I’ve been told about a few problems from the client. The one today being that they can’t add a link to selected text in a post. I had a look and when you highlight the text and click the link icon nothing happens. Tried adding the link using the Text mode instead of Visual, but the text tab no longer works either.
    Also a post now shows the username as the author and not the Public Display Name at the first level, once you click to view the post the author name changes to the display name.
    These used to work before the updates, could someone take a look please.
    http://www.pontesbury.info

Viewing 9 replies - 1 through 9 (of 9 total)
  • Some other items when adding or editing a post don’t work either: the ‘Add Media’ button, the ‘Screen Options’ wrap and the ‘Help’ wrap.
    I’m a bit stuck…
    Thanks for any help.

    It seems it’s not the template update because another WP site I have is the same when trying to post items.

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    All my WordPress sites are acting the same, surely these fixes would be relevant if only one particular one was playing up?

    I’ve tried the first three to no avail and am downloading everything via FTP before doing number four.

    esmi

    @esmi

    Forum Moderator

    There is no magic bullet in these situations. This is just the start of basic troubleshooting and is a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    I know, it just seems odd that six or seven sites are doing the same after updating WordPress in the last week or so. I’ll go through number four and see how it goes.

    esmi

    @esmi

    Forum Moderator

    http://www.pontesbury.info/ is not using the original Twenty Ten theme.

    We’ve made some adjustments to the CSS but I’ve already tried installing the original, even the updated version, but no luck.

    Sorted, found this:

    Just scroll right down to the bottom and look for this line at the end:

    /* That’s all, stop editing! Happy blogging. */

    Above this line, copy and paste this line of code:

    define(‘CONCATENATE_SCRIPTS’, false );

    Save the file.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Can't add link in post after updating’ is closed to new replies.