Support » Plugin: If Menu - Visibility control for Menu Items » can't add items to menu with plugin enabled

  • Resolved tonygaglio

    (@tonygaglio)



    Hello,

    Great plugin, strange glitch happens though. When the plugin is enabled, I cannot add new items to the menu. For some reason when I click the Add To Menu button it does nothing. I have to deactivate the plugin, add the new items, and then re-activate the plugin if I want to add new items. Seams to be a strange thing. Other than that, the plugin works great.

    Thank you very much

    https://wordpress.org/plugins/if-menu/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Colin

    (@colinsafranek)

    +1

    I’m having the same issue. Just noticed it a few days ago, but that was the first time I tried adding anything to my menus in a while (maybe a month), so I can’t say for sure when this bug was introduced.

    There are no JS console errors or PHP errors in the log, so I have no idea where to start troubleshooting.

    Any help would be much appreciated as the above workaround isn’t acceptable in my case.

    Thanks in advance!

    +1

    Have a WordPress install that’s just a few days old and have run into the same issue. Tried a few other plugins and finally found If Menu, at least it’s not just me.

    +1

    Able to successfully remove menu items with plug-in enabled. Existing settings on menu items are restored plug-in is re-enabled after adding a new menu item.

    +1 same for me (When the plugin is enabled, I cannot add new items to the menu).

    +1 same problem here, to add a menu item I have to disable the plugin!

    Plugin Author Andrei Igna

    (@andreiigna)

    Thanks for letting me know about this. I’ll take a look at it and release a fix shortly

    Just found this too, thanks for the quick response Andrei and good luck!

    Andrei,

    If you would like someone to test the fix, I have a test environment and could get back to you in a day or two. Also, let us know if you need debug info.

    @andrei: as I am testing your plugin atm in a test enviorment feel free to contact me if you need some test feedbacks.

    @all: As a dirty workaround do this:
    – deactivate the plugin
    – add the menu
    – reactive the plugin

    Also found this, agree with @gkz the solution while @andrei investigates is to disable, add what menu items you like, then re-enable the plugin.

    Thanks again for a great plugin Andrei!

    Colin

    (@colinsafranek)

    Any progress on a fix?

    I’ve just found this problem too, although this is the first time the issue has happened as I’ve used the plugin many times before. I think it must be an issue from around WP4.3+.

    I have also found this to be a problem but another big part of this is when I re-activate it after adding new menu items, some of my last menu items get deleted (always at the end). So I deactivate it again, add those deleted menu items back, re-activate it and then it’s fine.

    Here’s a good helpful hint on that. Anything after 75 menu items gets deleted. We have sub/sub/sub menus and so it doesn’t seem that many but that is the issue. Anything after 75 gets deleted once we re-activate the plugin.

    Hi,
    have same problem and workaround same way as suggested (switch off / add / switch on )

    Author seems forget about his own plugin support -)

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘can't add items to menu with plugin enabled’ is closed to new replies.