WordPress.org

Forums

[resolved] [closed] Cant add images to the Media section - error: Unable to create directory uploads (43 posts)

  1. kateswan11
    Member
    Posted 1 year ago #

    I can't upload any images to the Media section.
    I get an error message:

    “paintings-06.jpg” has failed to upload due to an error
    Unable to create directory uploads/2014/01. Is its parent directory writable by the server?

    I tried manually creating the directories, but this didn't help.
    I also tried changing the permissions, but with a Windows based hosting account there's not a lot to change. I also called up GoDaddy and had them reset the permissions, but that hasn't helped either.

    I recently moved my hosting account from one domain to another, and then upgraded to the latest WordPress 3.8.. so somewhere along the line something has gone wrong, but my hosting company (GoDaddy) can't figure it out either.

    I'm using the Virtue theme, but I had tried other themes too and it still wouldn't upload images.

    I can't upload images from within posts either.
    I don't have any images uploaded already so I can't test if I can insert images into posts.

    I tried uploading some images manually via my hosting File Manager but I can't see the images from within WordPress.

    I changed the Permalinks, but that didn't have any effect.
    I also unticked the box in the Media Settings section that organises files into month- and year-based folders.. still no luck.

    I have no idea what I'm doing, really, and no idea how to fix it.

    Someone, please help!!!

  2. Fathi
    Member
    Posted 1 year ago #

    You need to give permission to the uploader file to create the "January" or "01" month where your new images will be saved.
    To do that,just go to your C panel account, then File editor and locate the "wp-content" change permissions to that file "wp-content to 777 , next step is opening that file, and you will find the "uploads" file, change its permissions to 777 .the same things for the file "01" in that file 777 again.
    To conclude, you need to make the permissions 777 for all the files , wp-content, uploads, and the months inside that file also.
    Thus your uploader will work again.
    Don't forget to change permissions 755 for wp-content after the uploader works again.

  3. kateswan11
    Member
    Posted 1 year ago #

    I don't understand where 777 comes into it.
    When selecting permissions the only options I get are:
    -Inherit
    -Read
    -Write

    ALL are ticked.

  4. kateswan11
    Member
    Posted 1 year ago #

    Please help - it's still not working!
    There is nowhere to put/choose/add 777 or anything like that.

  5. Fathi
    Member
    Posted 1 year ago #

    I think you need to check this tutorial that show you how to edit the file permissions.

  6. Fathi Arfaoui? Once again, please do not send people to your site like that.

    http://codex.wordpress.org/Forum_Welcome#Helping_Out

    http://codex.wordpress.org/Forum_Welcome#Link_to_Your_Site

    Whether you agree with the forum welcome or not you have to abide by the rules. Forum support stays on the forums. It is too easy to abuse sending people to your own site and by helping here you will be assisting many others.

    Please do not do this again.

    Now back to our regularly scheduled support topic. ;)

    @kateswan11 Please give this Codex article a read about file and directory permissions.

    http://codex.wordpress.org/Changing_File_Permissions

    If you need aditional help I am sure someone can assist you on these forums.

  7. kateswan11
    Member
    Posted 1 year ago #

    Thanks Jan, but its still not working.
    I've set all the permissions with the File Manager of my hosting account, as well as via FileZilla.
    Its still not working!

  8. kateswan11
    Member
    Posted 1 year ago #

    I had also previously asked my hosting company to reset the permissions, which they did, twice, but its still not helped. They suggested that WordPress has a bug, and the error is caused by something else.. but they have no idea or suggestion.

  9. kmessinger
    Forum Moderator
    Posted 1 year ago #

    They suggested that WordPress has a bug

    Who? Do you have a name?

    If your site was actually up without the coming soon we could be more helpful but as it is there is nothing we can even check.

  10. kateswan11
    Member
    Posted 1 year ago #

    At the beginning of this post I said my website is hosted with GoDaddy.

    My website is up, but there isn't any content yet.

    Its here: http://www.miriambailey.com

    Its a website about art and I can't upload any pictures of the art!

  11. kmessinger
    Forum Moderator
    Posted 1 year ago #

    I know you said GoDaddy. I wanted to know who, by name that told you that because it is a bald-faced lie.

  12. kateswan11
    Member
    Posted 1 year ago #

    Ok, my ears mustn't be working properly either.

    This is not helpful.

    Everything else in WordPress works, except uploading images. I need a solution, and I have absolutely no idea what more I can do!

    The WordPress error says its a permissions error.. but I've set the permissions, and asked GoDaddy to set them, and I'm still getting the same error - therefore it is not unreasonable to say that perhaps WordPress is giving an incorrect error message.

    I was able to upload images before I updated WordPress. How do I roll it back to the previous version? I'll google that and try it.. if I can.

  13. kmessinger
    Forum Moderator
    Posted 1 year ago #

    Using the file manager provided by GoDaddy or ftp can you confirm you have a directory /wp-content/uploads?

    I know you said you created it - just checking.

  14. I'm not familiar with GoDaddy but when you say

    I don't understand where 777 comes into it.
    When selecting permissions the only options I get are:
    -Inherit
    -Read
    -Write

    ALL are ticked.

    Is there a way to do that recursively? Meaning you get all the folders underneath wp-content/uploads? If your host is linux based and you have ssh access then I can walk you here through how to set that 777 if that's what's going on.

  15. kateswan11
    Member
    Posted 1 year ago #

    Yes, it was already there.
    There are files in there from 2012 and 2013, because I'd previously had different content on this hosting account.
    I can't actually view any of that content through WordPress, though.

  16. kateswan11
    Member
    Posted 1 year ago #

    No, its Windows based as I mentioned in my first post.
    I opened up FileZilla and changed the permissions to 777 (and all the child files & folders) of the wo-content folder.

  17. kmessinger
    Forum Moderator
    Posted 1 year ago #

    I've set all the permissions with the File Manager of my hosting account, as well as via FileZilla.

    Did you set them to 777? The uploads folder and the 2014 folder and the 01 folders

  18. kateswan11
    Member
    Posted 1 year ago #

    Yes. All of them.
    The 2014 and the 01 folder that was inside the uploads folder was created by me when I was first trying to troubleshoot the problem.

  19. No, its Windows based as I mentioned in my first post.

    Sorry, I missed that part.

    Nuts, how does Windows do ownership...

    This loads sorta.

    http://miriambailey.com/readme.html

    But the logo is not loading when the referrer is set.

    http://miriambailey.com/wp-admin/images/wordpress-logo.png

    But the logo itself will load directly just not called from that readme.html

    And the problem appears to be that WordPress (via PHP) isn't being allowed to create directories.

    I can't actually view any of that content through WordPress, though.

    It's a new site so there's no old content which is a shame.

    Can you show GoDaddy this link?

    http://miriambailey.com/readme.html

    Ask them why the logo does not load but does load directly.

    http://miriambailey.com/wp-admin/images/wordpress-logo.png

    Something is really odd going on. That html file doesn't have any PHP and it's not working.

  20. kmessinger
    Forum Moderator
    Posted 1 year ago #

    Here is the strange part for me. When I go to http://miriambailey.com/wp-content/uploads/ I get a 404 error (not found). I should get a 403 error.
    That means the browser was able to connect to the website, but it does not have permission to view the webpage.

  21. kateswan11
    Member
    Posted 1 year ago #

    There was old content, but I deleted it all from within WordPress and/or changed it when I transferred the hosting account to the new domain.

    I can delete EVERYTHING via FileZilla if I have to and reinstall WordPress and start from scratch... but it would be good to find a solution so I don't have to do this.

    I'll ask GoDaddy about the logo.. unfortunately they take forever to respond via email so I'll have to call them, but its 1.30am here and I'm tearing my hair out and will likely shout at them, so I'd better sleep on it.

  22. I'll ask GoDaddy about the logo

    Yes please. It may not have anything to do with the uploads directory (or it may) but that's just an HTML file. If they can't serve that correctly then frankly you ought to dump them like a sack of hot bricks...

  23. but its 1.30am here and I'm tearing my hair out and will likely shout at them, so I'd better sleep on it.

    Oh. WOW. Yes please do take a break. This is not worth that level of aggravation.

    This will still be there tomorrow. ;)

  24. kateswan11
    Member
    Posted 1 year ago #

    I'm at the point where I want to dump my whole computer out my window.

    Thank you so much to you both for trying to help... I'll check with GoDaddy in the morning and will come back here to update.

    Thanks.

  25. Last night someone pointed out to me that It may not be GoDaddy. See this trac ticket.

    https://core.trac.wordpress.org/ticket/26781

    It pretty much describes what you are going through.

    Since this is a new or at least empty installation are you game to try something different?

    Visit this page.

    https://core.trac.wordpress.org/browser/trunk/src/wp-includes/functions.php?rev=26926

    At the bottom is a link (which you can click using this link) and that will download a copy called functions.txt. Save that to your PC.

    Now renamed that file to functions.php (make the .txt read .php) and upload that to your server into the wp-includes directory so that it overwrites the existing file.

    Once that's done try and upload media to your installation in WordPress.

  26. kateswan11
    Member
    Posted 1 year ago #

    I rolled back to WordPress 3.6.1, but STILL can't upload images.
    Waiting for a response from my host, GoDaddy.

  27. kateswan11
    Member
    Posted 1 year ago #

    Another thing I noticed, is when I changed the permissions to 777 in FileZilla the log says
    Response: 500 'SITE CHMOD 777 wp-content': command not understood

  28. kateswan11
    Member
    Posted 1 year ago #

    GoDaddy are going to transfer my account from Windows to Linux. Hopefully that will fix the problem.
    I'll mark this thread as resolved and move on with my life!

  29. kateswan11
    Member
    Posted 1 year ago #

    By the way, I tried the function php file thing, but still no luck.

  30. kateswan11
    Member
    Posted 1 year ago #

    Just thought I'd update..
    Switched from Windows to Linus hosting. Uninstalled WordPress and reinstalled. Problem fixed. No idea what caused the problem. Since I had only just started setting up the website it wasnt too much of a set back to wipe it and start again.

Topic Closed

This topic has been closed to new replies.

About this Topic