Support » Fixing WordPress » Can't add images to posts or edit existing posts with images

  • Resolved modernape


    Since 3.5.1 I can’t edit existing posts if they contain images, nor can I add images to new posts. When I click on ‘Update’ after editing a post, my browser gives me an error message that the web-page is unavailable “because the server where this page is located isn’t responding”. If the post has no images, then the update is saved.

    Similarly, the Media Library displays empty, despite images having been uploaded into the correct folder (wp-content/uploads), and when I try to upload new images with the multi-file uploader, I just get the message “failed to upload due to an error –
    The uploaded file could not be moved to /…/wp-content/uploads.”
    If I use the browser file uploader, I get this:
    “Error saving media attachment”.

    I have gone through the troubleshooting master list, deleted all plugins, switched to the latest version of the twenty eleven theme, tried three different browsers, re-installed 3.5.1 again, pasted define(‘CONCATENATE_SCRIPTS’, false ); into wp-config.php; tried inserting images from a URL rather than the library; all to no avail.

    Any ideas what to try next?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi I am no expert but have you tried re-saving your permalinks, dont change anything just re-save.

    Long shot but you never know! Also have you looked in your upload folder via FTP? Are there images in there?

    Yes, the images are definitely there in the uploads folder.

    What makes you think this has anything to do with permalinks?

    web page unavailable .. you have tried the obvious with permissions?

    Moderator kmessinger


    Have you talked to your hosts? WordPress needs a temp folder on the server. Maybe something has changed on their end.

    Where is the wordpress temp folder usually located?

    When you say posts with images. Are the images featured images or in the content or both?

    Trying to establish if one or the other causes the issue. It’s a strange one.

    Did you disable all plugins, especially gallery/image related ones that may hook into actions you take on Edit Post screen?

    Or, more importantly perhaps, how can I diagnose if that is in fact the problem?

    Moderator kmessinger


    It is set by your host. You will need to contact your host and ask them if they specified a temporary directory (e.g. upload_tmp_dir in php.ini)

    Damn it, it was a mis-configuration by the server host of their ‘intrusion prevention apps’. They’ve now resolved it, it was nothing to do with my install (GRRRRR!)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can't add images to posts or edit existing posts with images’ is closed to new replies.