WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » Can't Add Images to NextGen Gallery Anymore

Can't Add Images to NextGen Gallery Anymore

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same here. Trying to add new images to a gallery. It seems to go through all the motions but when I check for the images they are not there. Someone has screwed up big time.

    Same here!!

    Upgraded from 1.9.12 to 1.9.13 and image upload is now impossible. It doesn’t matter which browser I use.

    I hope this can fixed immediately!

    thx.

    I think I’m going to try reloading 1.9.12. I’ll let you know if it helps. It will be later today.

    hmm I too am suddenly having trouble, though I haven’t upgraded recently (unless my client did) it seems to be up to date 1.9.6. I am getting this error below when I try and upload new images to an existing gallery. Though permissions haven’t been changed on the folder and I’ve uploaded without problem before, though not for a while.

    Unable to write to directory /wp-content/gallery/jericho. Is this directory writable by the server?

    Any ideas anyone?

    OK. I reloaded my backup that had NextGen version 1.9.12 but it didn’t solve the issue. So I tried activating the WordPress Default Theme in place of my current theme. When I do this I am able to upload photos with no problem. Then I just changed back to my theme.

    It appears there are issues with NextGen compatibility with certain themes. I’m using Inspiration, a premium theme I purchased from ThemeForest about 16 months ago. I don’t think there have been any updates to this theme so I suspect that is part of the problem. I have a hard time finding support on their website.

    Now that I figured that out I’m not sure where to go from here but at least maybe you can go back to the Default Theme to load your pics.

    OK thanks Jackied1203 I will try doing that. My theme is a child theme I built based on twentyeleven. Tryin this I will at least discover if it is a server permissions issue in my case or a sudden theme issue…

    nope it wasn’t a theme issue, I get the upload permissions error in default theme so must be a server side issue for me

    igloobob,

    Yes it sounds like it is a permissions issue for you. I am not getting an error message at all. The images simply do not load into my galleries.

    You can check and change your permissions using an ftp client. Connect to your site on the server then go to the file that you named in the error message, select it and right click. You will get a drop down list that includes File Permissions. Select this and change the numeric value to 777.

    Hope this helps with your issue.

    Yes I had tried all that but the permissions seem correct. I think the host might have changed something. I remember when I was setting this site up for my client initially we had loads of problems with the host having super tight permissions that were blocking loads of wp features. I’ll see what they say..

    isn’t 777 unsecure though as it allows all people to write and execute?

    try to deactivate plugins and activate again.

    In the I also ended setting the permissions to 777. I think it’s not the smartest of solutions, but it did the trick….

    Plugin Author photocrati

    @photocrati

    Sorry to hear about this! I have tested multiple times on my test sites to try and replicate this issue, but this does appear to be an isolated issue, or incompatibility issue as @jackied1203 found. Thanks for all the help everyone (@smit_ralph, @imbecyl, @jackied1203) in trying to figure out the cause of this. @igloobob – you wont’ want to leave your site with 777 permissions, that is very insecure and will leave your site wide open to hackers. You shouldn’t have to go above 755, it should work with 755 permissions. Though, permission errors do indicate a write problem, so you may bring this up with your server host tech support and see if there are any settings they can adjust from their end. It may be they have additional security settings in place somewhere, you might ask if they have PHP Safe mode turned OFF and if they have it set to ON, request they turn it OFF. Another thing you might try is deactivating all plugins (including NextGEN Gallery) and then re-activate NextGEN Gallery only. If that doesn’t do the trick, switch your theme to Twenty Twelve, > clear browser cache, and try again. Still having only NextGEN Gallery activated.

    I hope that helps! 🙂

    –Becky

    Becky – Thank you for all of your good input. It’s unfortunate that my Theme appears to be causing the problem. I have tried to contact Themeforest where I purchased the theme and have not heard back from them. I think the lesson I learned here is to stick with the themes available on WordPress. At least you know you can count on updates and support.

    Hello all,

    in my case it was a server issue that has now been fixed by the hosts. The permissions on my gallery folder are currently 765, should I be making these 755?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Can't Add Images to NextGen Gallery Anymore’ is closed to new replies.
Skip to toolbar