Support » Fixing WordPress » Can't add images!!!

  • Resolved mlesoing


    I’ve had my blog for a couple years now so I’m fairly familiar with getting around. I just changed my theme to Suffusion By Sayontan Sinha and went to edit a post only to discover that the “Add Media” button doesn’t function. I can click it but nothing happens. I’ve tried it in both Visual and Text modes, and in other posts. I tried re-starting my computer and logging in again. I tried updating the page. I tried refreshing the page. Nothing seems to work.

    The page in question is and somehow I’ve got a dead link to a photo there at present. I’ve deleted that, but put it back in making another attempt.

    I’m thinking (HOPING) it’s a very simple fix, but I am going absolutely crazy trying to fix it. I’d like to add images and have the ability to move them around or put text around them as I’ve done for years, but it simply doesn’t work. If anyone can help I’d REALLY appreciate it!

Viewing 5 replies - 1 through 5 (of 5 total)
  • WordPress recently changed how the Add Media button works. If the theme you switched to was doing wacky things with an old version of that button functionality, that could be your problem. Try switching themes, adding your image, then switching back. If that works, you should contact the theme author and report the bug.

    I’m going to try this. At the same time, I’m thinking I’ll lose all my valuable settings and widget placements for my current theme if I change themes and then switch back. Is that true? I’ve been spinning my wheels for so long now I’d hate to try this and have to rebuild my wheel. Know what I mean? Maybe there’s a quick and simple way to do with while saving settings and etc.?

    jimisdon, thanks SO much for your help!

    I could be wrong, but I believe your widgets will retain their settings unless you change them in the new theme. Sounds like not being able to upload images is a showstopper worthy of spending time re-configuring your widgets if necessary, though.

    Yep, you are absolutely right, of course. Spending time getting it right now will save time in the long run. Doesn’t it seem, however, that sometimes life come to a grinding halt?!!! Ha! Thanks so much, and I’m going to try this right now….. (crossing my fingers)

    jimisdon, here’s my update. I changed the theme and changed back immediately. Good news, all my widgets and etc were saved (Yeah!), but the Add Media button still doesn’t function. I switched back to the other theme, just to see if this glitch is something that is going to follow me for the rest of my life and, lo and behold, the Add Media button WORKS! Maybe I’ll just avoid the headache and change themes again. Ugh… all that changing font, font color, blah blah blah to do over again, but hey, at least it will work! Anyway, can’t thank you enough! Much appreciated. Have a great day!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't add images!!!’ is closed to new replies.