WordPress.org

Forums

Social
Can't add Facebook account (22 posts)

  1. ingy_dust
    Member
    Posted 1 year ago #

    Hello,

    I can't add Facebook account to my admin user. Twitter is working perfect and I connected admin with Twitter account, but Facebook box doesn't show connection on /wp-admin/profile.php#social-accounts (it says Facebook: No Accounts). If I check my Facebook account I have Social Proxy by Mailchimp with all privileges there. Please help!

    Tnank you in advance!

    http://wordpress.org/plugins/social/

  2. WisTex
    Member
    Posted 1 year ago #

    It lets me add Facebook, but then when I try to broadcast it says that it has the wrong password. Twitter works fine for me as well.

  3. Alex King
    Member
    Plugin Author

    Posted 1 year ago #

    We have seen sporadic reports like this but never been able to reproduce it. Patches are welcome if anyone can reproduce and identify a necessary fix.

  4. felixone
    Member
    Posted 1 year ago #

    hey,

    I can't add neither twitter, nor facebook to social options :(
    The popup appears and i can connect it to my acc, but it doesnt show up in the plugin options.

  5. aarseth
    Member
    Posted 1 year ago #

    I am having a similar issue. Twitter works fine, but Facebook won't connect.

    There is a generic head icon beneath the Sign in with Facebook button. When I click the button, a new browser window opens, then closes, and the page refreshes. However instead of showing my Facebook profile picture, it looks the same as before.

  6. pet artist
    Member
    Posted 1 year ago #

    The same happens on one of my new wordpress websites. In the "profile.php" page, at the bottom, it says:
    Facebook Account
    Get started
    but there is no active link to open. What can I do?

  7. chava2uk
    Member
    Posted 1 year ago #

    I have the same problem as pet artist. I just installed the latest version of WP today and added the Facebook app. I just can't add my Facebook logins to WordPress to use it

  8. aarseth
    Member
    Posted 1 year ago #

    Same thing with me… Twitter works fine. Facebook launches a little blank window which closes immediately, and the account does not connect.

  9. aforgottenman
    Member
    Posted 10 months ago #

    I used to have a connection to facebook, but now there is only an option to connect. When clicked, I get the following: Something which should never happen, happened. Sorry about that. If you try again, maybe it will work.

    Error code: -10520

    There is no option to "Add New as there is for all the other social media link choices.

  10. aforgottenman
    Member
    Posted 10 months ago #

    I forgot to mention that I am trying to use the Publicize module in Jetpack for WordPress.org sites

  11. Jonnyirish
    Member
    Posted 9 months ago #

    same problem here

  12. jmboyd
    Member
    Posted 8 months ago #

    Can't add Facebook account. Twitter working fine.

  13. Alex King
    Member
    Plugin Author

    Posted 8 months ago #

    I'm very sorry you're having this problem. I believe that you're experiencing this and I'm sure it is very frustrating. I hope you will, in turn, believe that we cannot reproduce this problem and that we would fix it if we could. If you are able to debug the problem, identify it, and provide a fix please open a pull request here. We will be very grateful Thank you.

    https://github.com/crowdfavorite/wp-social

  14. dlature1
    Member
    Posted 7 months ago #

    Several people are having the problem. I am not able to post to Facebook. And after I removed the Facebook option and tried to re-connect it, I no longer have any option to do so. I only removed it because it had been inoperative for quite some time, and inconsistent at best.

    update: went to another machine and the same behavior there. When I click "Connect with Facebook" on the settings page for Social, absolutely nothing happens, unless you count the page blipping as if it just reloaded very quickly, but no login prompt for Facebook or anything. Something is broken, guys. You need to do something beyond just saying "we cant duplicate it". It's widespread. And nothing is different now that I'm on WordPress 4.0, except that lately, it NEVER posts to Facebook, which is differetn from the usual 10% success rate for Facebook. Meanwhile, Twitter works every time. Seems like Facebook has made some changes that this plugin hasnt kept up with.

  15. dlature1
    Member
    Posted 7 months ago #

    here is my wordpress plugin settings page for Social http://theoblogical.org/socialBroadcastSettings.jpg

  16. dlature1
    Member
    Posted 7 months ago #

    Again, this morning, totally uninstalled Social and removed its files. Went into Dashboard to Plugins and re-installed it. Still nothing. "No accounts" still shows just like it did in the screenshot I showed in my last post. There is OBVIOUSLY a problem here, Alex, and I don't know what to do to fix it, or what is causing it not to work. It had been working until the last couple months. It started being inconsistent, and now it doesn't connect EVER. Seems Facebook API tweaks are needed to restore it to working order for many who have been using this (as I have) for quite some time.

  17. dlature1
    Member
    Posted 7 months ago #

    Hey Alex, just saw this. What's this about?
    "V2.7 of our WordPress Social comments plugin updates the proxy service it uses. You'll want to upgrade before Jan 15 for the plugin to continue working. http://j.mp/S9l9qT" (from https://www.facebook.com/mailchimp/posts/10151352295560777)
    the link takes me to the WordPress Plugin page for Social 2.11. Is the 2.7 version referring to something different than the current 2.11 for Social?

  18. johnbiggs
    Member
    Posted 7 months ago #

    Not exactly sure if this is related, but this is the error it throws for Twitter authorizations. Can't imagine it's much different.

    [SOCIAL - 2014-09-07 15:10:04 - 38.126.117.10] Running request: Auth/action_authorize
    [SOCIAL - 2014-09-07 15:10:04 - 38.126.117.10] Authorizing with URL: xxx
    [SOCIAL - 2014-09-07 15:10:08 - 50.23.108.137] Running request: Auth/action_authorized
    [SOCIAL - 2014-09-07 15:10:08 - 50.23.108.137] Failed to verify authentication nonce.

  19. Cang Luo
    Member
    Posted 7 months ago #

    Hi All,

    I have posted a solution that will temporarily enables you to add accounts. Once you add the accounts, everything should work as before.

    See: http://wordpress.org/support/topic/cant-add-twitter-accounts?replies=6#post-5989082

  20. dr_monkeyface
    Member
    Posted 7 months ago #

    +1 to the solution by Cangluo. This issue has been annoying me for several months now.

  21. zenobiastudios
    Member
    Posted 7 months ago #

    Hi- any chance anyone has an easier fix to this problem? I'm a novice and have no clue how to implement the aforementioned fix. My Twitter is fine but I can't get the Facebook account to connect : (

  22. acaweb
    Member
    Posted 7 months ago #

    cangluo you are BRILLIANT...Thank you for the fix :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Social
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic