WordPress.org

Support

Support » Plugins and Hacks » Simple Email Subscriber » [Resolved] Can't add E

[Resolved] Can't add E

Viewing 15 replies - 1 through 15 (of 15 total)
  • Simple E adds “blogg” (exemple.com/blogg/blogg/…) in my URL when you press subscribe or want to add an address to the list.

    Plugin Author phil88530

    @phil88530

    Can you give more details about how to reproduce this error please. AS far all the posts(apart from clicking the unsubscribe link in email) are POST requests, you shouldn’t see anything in your url as blogg.

    I can confirm there is nothing in this plugin contains ‘blogg’ as well.

    I have the same problem. This is a path problem. My blog is installed in a subdirectory of webroot “wp” and on submission of the form the plugin is adding wp to the end of the site URL which takes the user to a page that does not exists – hence the 404 error.

    The issue is I think to do with the use of get_site_url() which appends the path of the subdirectory that WP is installed in. Try home_url() instead

    Plugin Author phil88530

    @phil88530

    nice malcolmlm, I shall have a look and update it once it’s solved

    Plugin Author phil88530

    @phil88530

    1.3 is now live and shall resolve this issue.

    Hi, it’s still not working. Can you tell me the file name and line number of where the form tag is generated and I’ll have a look and fix for my site and let you know what I did.

    Plugin Author phil88530

    @phil88530

    if you seeking the admin_page add/remove subscription, it will be in admin_page/admin_page.php

    if it’s the widget, it wil be includes/widget.php

    I do notice that the widget.php still using get_site_url() <- just one of the line I forgot the change really.

    I’ve made further changes, give it a try otherwise fix it yourself and let me know

    Cheers
    Phil

    Now I installed 1.4, but the problem remains. “/ blog” which is my subfolder in the URL is added to make it / blog / blog when I choose to subscribe.

    Plugin Author phil88530

    @phil88530

    Hey:

    If you going to your blog admin:settings->general

    and change your wordpress address and site address to be your blog url, it should then work

    The thing with wordpress is that you have to do some correct configuration of your blog site in the first place, otherwise many things can go wrong.

    just installed latest and it works for me apart from no success message is displayed

    Plugin Author phil88530

    @phil88530

    Hi malcolmlm:

    There isn’t a sucessful message setup atm, will make it up soon.

    good to know it’s now working

    Hi,
    I’m just trying different subscription plugins as I havent’t found the perfect one for me yet.
    Yours could be a candidate for me but there is still a huge issue.
    The problems above with site_url and home_url I checked and set all up correctly. In the first place, I hat also the problem with an additional subdirectory string in the url when submitting.
    Now I’m fine when submitting, BUT if the user is entering nothing or a wrong email adress (happens all the time) and gets the error message, then correcting it instantly and submitting again, THEN I do have the problem with the second subdireoctry string in the url again.
    So the string in the first place still is a bug I think, because it somes up again if the user has to submit twice cause of error messages.

    Could you have a look at that? I think if you got a solution for that, the problems metioned above aren’t any issue anymore either way.

    Plugin Author phil88530

    @phil88530

    HI:

    will have a look in next month, and will update this plugin with more category subscriptions as well. just bear with me 😀

    Ta

    Plugin Author phil88530

    @phil88530

    Dear j-c-r-w:

    I just had a deep look of your issue, it happens when: because wordpress itself is designed to not accept extra parameters(unless you code and tell workpress to accept certain ones)

    so it is not a plugin issue.

    Please read this post and get some hints:
    http://www.webopius.com/content/137/using-custom-url-parameters-in-wordpress

    There will still be a plugin update soon for more features, and I hope you all the best

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Can't add E’ is closed to new replies.
Skip to toolbar