Support » Fixing WordPress » Can't Add, Delete, Update Plugins after migration

  • Resolved kirktalon741


    I’ve tried to search for this and have not felt comfortable with the results cause of the age of the post(s) or not seeing exactly the same problem.

    These problems come after a migration from one server to another and use of a new URL.

    Updates seems to be happening in the same way as usual but take a long time with the browser busy effecting the change. Then the dashboard says it is done “successfully” only to show in the plugins it still needs to be done.

    On WordPress plugin Adds or installs, I’m getting confirmation that it has been installed.
    Then I get this message when I try to activate it.
    “The plugin does not have a valid header.”

    Delete of a plugin gets one of two things. First the message that the plugin is removed but it is not when I inspect the list of plugins.

    OR I get this message . . . .
    “Plugin could not be deleted due to an error: Could not fully remove the plugin(s) event-espresso.3.1.15.P/espresso.php.”
    (This message came with Event Espresso plugin attempting to delete older version. This happens with all plugins. Removal can be done through ftp.)

    I’ve had to input FTP username and password before being allowed to attempt to install, update, or delete a plugin.

    The Webhost said it has a “secure (or “hardened”) php, by default”.

    I hard coded this into the wp-config.php to bypass that.

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. ]

    //*added ftp login credentials to avoid WordPress asking for FTP details every time I wanted to upgrade a plugin*
    define('FTP_HOST', '');
    define('FTP_USER', 'ftp_user_name');
    define('FTP_PASS', 'ftp_user_password');
    //*If you can use a SSL connection set this to true*
    define('FTP_SSL', true);

    Thanks in advance for the help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    With your FTP client, can you confirm the file ownership and permissions of a plugin directory that you are having problems with?

    And using those credentials by hand, can you confirm that you can delete a plugin directory and upload the new version manually?

    I want to confirm that your FTP credential are working outside of WordPress.

    Yes, I can do all those things using my FTP client. That was the only way I could get the latest versions of the Event Espresso plugins into my WordPress.

    My apologies for not getting the posting coding protocol right. I’ve removed the above coding from the wp-config.php file. The website now asks for FTP inside WordPress again. Still no updating going on.

    Is your ftp settings set to folder 755 and files 644?
    Have you changed the wordpress url inside the database?

    Yes to your first question. Yes to your second question to the best of my ability. I went through each part of my database using PHPmyAdmin and changed the URL there everywhere I saw it.

    I’ve used the search and replace plugin in the past.

    I just spoke to my client’s webhost. It was explained to me that they are primarily a web developer aka make websites for others themselves. They have decided to use “Hardened PHP” instead of regular(?) PHP. This to insure the sensitive things they do like eCommerce stays maximally protected.

    This makes the dashboard functionality of WordPress with plugins and image files impossible or necessary to do via FTP. The FTP being to change file permissions of folders and files/folders inside those folders temporarily to get functionality. If that fails, the next step is to add and delete via FTP exclusively.

    I judge that to be WordPress unfriendly.

    Thank You to all those who tried to help. I appreciate it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can't Add, Delete, Update Plugins after migration’ is closed to new replies.