Support » How-To and Troubleshooting » Can’t Add COMMENTS after 2.5! Please Help!

Can’t Add COMMENTS after 2.5! Please Help!

  • I’ve tried before and can’t seem to get any kind of response… so, I’m trying yet again to get some help.

    I’ve finally upgraded to 2.5… I have a lot of pics on my blog, so the gallery function is going to be needed and used a lot!

    (my blog is located @ http://www.ez-entertainment.net/blog/

    As for the comments… they don’t seem to be showing at all on the regular pages (and I NEED them there!)… and when I do an image gallery page (http://www.ez-entertainment.net/blog/?p=71 and click one of the thumbnails) it did show in a text link, that I could leave a response, but I got this error:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <message>I really need an ID for this to work.</message>

    I may need to upload something else, I don’t know… to get the gallery/album page, I had to upload the one from the ‘default template’ file as suggested in another thread. I don’t know if it’s trying and can’t reply to an ‘attachment url’ or what the deal is… but, if someone can help, I’d GREATLY appreciate it!!! I just want my comments back!!! I don’t want to edit any more posts until this gets worked out. And, they NEED to be edited as there are so many pics, it slows down the home page.


Viewing 15 replies - 1 through 15 (of 26 total)
  • Well, I’ve been pulling my hair out, so I went to my php-admin, but I’m illiterate with databases! So, I’ve made a web page with what the “comments” table had on it… maybe it will help someone guide me to a fix. ?? I’m also concerned with the error message at the bottom (in red).


    Still waiting for a WP genius to help me!!!!! PLEASE???!!!!!

    I’m having the same problem too.

    Mine is a fresh install, and visitors do not have a comment box.

    My configuration is as follows:

    1. Settings –> Discussion –>
    a. Allow people to post comments on article
    b. Anyone posts a comment
    c. An administrator must always approve the comment
    d. Comment author must fill out name and email

    2. Write –> Pages –> Advanced Options –>
    a. Comments & Pings…Allow Comments
    b. Password Protect…blank

    What am I missing?

    Well, I did find another thread that did help at least for the home page posts… (http://wordpress.org/support/topic/151927?replies=8) I adjusted the header in my theme folder, that at least gives me the pop up comment box, but I still don’t have a comment option on the single page. I’ve checked the codes on both “page” and “single” in my theme, and they both look correct and I didn’t change the theme at all when I upgraded anyway.
    I also have the same settings as you have above… I don’t have it that mod must approve or they must be registered members, but there’s nothing on that admin dashboard page you could do to ‘fix’ this one.

    I’m at a loss…

    I reinstalled WP in a different URL…thinking maybe there’s something wrong with what I did the first time.

    The comments for posts are working…but there are no comments available for pages.

    This is plain vanilla WP 2.5, using Kubrick, and not even 1 plugin installed or activated.

    So you are getting the single page post comments working then, huh? Just not the ‘pages’? Well… you’re two up on me!!!haha I can’t get the post page OR a regular page showing comments. Only the index page. This BITES!!! I’m SICK to death of sorting through code, and just wish someone could clue us in on a fix for this!!!

    Isn’t it a bit pointless to have a blog and NOT be able to let people comment???!!!! uugghhh… soooo tired of trying to work this out!

    Surely, there’s some PHP wiz out there that can help us two desperate souls here… ???????? PLEEEEEEAAASE???!!!

    This seems to come from the theme. Try with the default theme.


    I’m sorry…my mistake, but I am using the default theme; and the page doesn’t allow comments.

    I doubt the developpers do not have tried the default theme.

    I didn’t touch my theme folder though when I upgraded, so that’s why it doesn’t make sense to me… ?? I DID adjust the header in my theme just so it would at least allow pop up comments on the index page, but that’s all I did. That was only because I wasn’t able to click the comment link on any page anymore and get a reply box. It just takes me to the post page. And, on those pages, I don’t even have an option for a comment.

    Same problem here but solved now
    , you need to edit the Page (page.php) template and add:

    <?php comments_template(); ?>

    Just after:

    <?php edit_post_link(‘Edit this entry.’, ‘<p>’, ‘</p>’); ?>

    Let me know if it works


    YES! It did work, Quique.

    However, now I have 1 more problem, now it says:

    Leave a Reply
    You must be logged in to post a comment.

    Here are my Discussion Settings:

    Default article settings:
    Check – Allow people to post comments on the article
    Before a comment appears:
    Check – Comment author must fill out name and e-mail

    Didn’t work for me 🙁

    I think it may be because I’ve got the ‘related posts’ and a google ad, maybe they interfere with where I’m supposed to put your code. When I tried it, it took out both related posts and the google ad…. so, maybe it’s supposed to go somewhere else…??? I have NO clue!!!haha If you do though… I’m ALL EARS!!!!!!!


    Hi simonsopinion!

    Good to hear it worked!

    Check Settings/General/Membership:

    “Users must be registered and logged in to comment” , just uncheck it.


    Hi callaweb:

    Which “Related posts” plugin are you using? I’m using WASABI’s v.2.04. and yes, looks like it conflicts with Google ads but no problem displaying the comments form. I’ll look for a new related posts plugin as WASABI’s is no longer supported.

    I’ll post an update if I make it work


Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Can’t Add COMMENTS after 2.5! Please Help!’ is closed to new replies.
Skip to toolbar