Support » Plugin: FireStorm Professional Real Estate Plugin » Can't Add Additional Images

  • I can add the main featured image, but then it won’t add any further images at all, nothing happens when the listing is saved.
    I am really pleased with the plugin other than that but I am waiting for my site to go live and cannot do it until I can add additional images.

    I don’t know if it has anything to do with the above issue but it also says “The FireStorm Real Estate Plugin Listing Page Must Contain The Following Shortcode: [fsrep-listings]”, it doesn’t automatically fix when clicked, and my page already contains this shortcode.

    My site is http://www.thalassabeachresort.com/rentals/

    Many Thanks

    http://wordpress.org/extend/plugins/fs-real-estate-plugin/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author FireStorm Plugins

    (@wfernley)

    Hello,

    Please verify you have the following directories created and they have write permissions:
    wp-content/uploads/fsrep/houses/additional/
    wp-content/uploads/fsrep/houses/additional/small/
    wp-content/uploads/fsrep/houses/additional/large/
    wp-content/uploads/fsrep/houses/additional/temp/

    Hi,

    Yes I have these directories and they have the permissions as follows:

    flcdmpe (0755)

    I also have another directory in additional called medium.

    Thanks

    Plugin Author FireStorm Plugins

    (@wfernley)

    Do you have access to your error logs? See if any errors appear when trying to upload an additional image.

    I have access to everything, but I can’t find any error logs, I’m hosted with 1and1. I’ve looked all through the logs folder and it only has mail and access logs.

    I go to the listing, click Browse under Add Additional Images then choose my file (158k) then click save and nothing happens. The page then goes to a blank page with this error at the top – Real Estate Plugin Error: The plugin requires allow_url_fopen to be turned ON however your server has this function turned OFF. This function is used to obtain listing coordinates for Google Maps. To turn this function on, add “allow_url_fopen=ON” to your php.ini file or contact your hosting provider.

    However I don’t think this has anything to do with the images?

    Plugin Author FireStorm Plugins

    (@wfernley)

    That function is required by Google Maps to run correctly.

    Can you please submit a support ticket on our website regarding this issue? The url is http://www.firestormplugins.com

    I have submitted a ticket twice, but they’ve been marked as resolved by someone?

    Plugin Author FireStorm Plugins

    (@wfernley)

    Sorry to hear that. I tried checking for your username but it looks like you are using a different username on our website. Can you send a message through the contact form on http://www.firestormplugins.com with your username. I will look into your tickets. Thanks!

    Hi. I have that problem too…

    When I add picture, nothing happens. The image is not uploaded to the server.

    Plugin Author FireStorm Plugins

    (@wfernley)

    Hello,

    I responded to your other post.

    swolfram

    (@swolfram)

    same prob here as threadstarter phoenix.
    write permissions are set even to 777 but nothing happens than a blank page. also it says this error about “url_fopen” but i just ignored this because i dont’t want to use google maps and disabled every possible checkbox.

    swolfram

    (@swolfram)

    Logfile says following

    GET /wphavelberg/wp-content/plugins/fs-real-estate-plugin/js/calendarDateInput.js HTTP/1.1″ 500 …..
    GET /wphavelberg/wp-content/plugins/fs-real-estate-plugin/js/ajax.php HTTP/1.1″ 500 …..
    POST /wphavelberg/wp-admin/admin.php?page=fsrep_listings&hid=1&f=edit HTTP/1.1″ 200 …..
    GET /wphavelberg/wp-content/plugins/fs-real-estate-plugin/gmaps.js HTTP/1.1″ 404 …..

    phoenix222

    (@phoenix222)

    I have fixed this problem now and you do need to sort out the url_fopen thing to get it to all work. I didn’t want to use google maps either so I tried turning everything off but still had the problem and I tried setting it all to 777 but that didn’t work either.

    I found that the issue with adding extra images was solved by resolving the allow_url_fopen issue. I wasn’t really sure what to do about it, so I created a php.ini file in each of the directories until the issue resolved. I think in my case the php file had to be placed in the ‘thalassabeachresort.com/rentals/’ folder (my main folder for this part of the site). I guess in your case it will need to go in /wphavelberg/ folder?

    The php.ini file was just a notepad file containing:
    allow_url_fopen = on

    Hopefully that will solve your problem for you.

    swolfram

    (@swolfram)

    Hi. 10 mins ago i found the same solution to the problem. I finally activated “allow_url_fopen” in php.ini for those installation and now everything works fine.

    I think the author should just correct the errormessage to say: IT IS NEEDED IN ANYWAY for this plugin to work 😉

    Thanks for your reply

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can't Add Additional Images’ is closed to new replies.