Support » Plugin: Media Library Assistant » Can’t add a tgz file

  • Resolved jcochennec

    (@jcochennec)


    Hi,
    This plugin works great but when I try to upload a .tgz file, I get a “not permitted for security reason” error message.
    I added a mime type for tgz extension, with application/gzip type, but it didn’t change anything.
    Did I forget something?
    Thanks.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your report. WordPress uses the PHP “fileinfo” extension to verify the content of many file types and this sometimes fails. MLA’s “Known File Extension/MIME Type Associations” list shows four different MIME types for file extension “tgz”:

    application/gnutar
    application/gzip
    application/x-compressed
    application/x-gzip
    

    It’s possible that one of the four will work for you. If not, can you post a link to one or more of your files so I can investigate further? You can also contact me at my web site to get instructions on how to email me some files to test with.

    I will leave this topic unresolved until I hear back from you. Thanks for your interest in the plugin.

    Plugin Author David Lingren

    (@dglingren)

    It has been a month since my last post in this topic. I assume you have found a solution for your “tgz” upload problem.

    I am marking this topic resolved, but please update it if you still need assistance.

    Plugin Author David Lingren

    (@dglingren)

    @jcochennec

    I have added a new “Always Use MLA MIME Type” option to the Settings/Media Library Assistant Uploads tab to override the WordPress “security” checks that probably causes these uploads to fail. You can find more information in the “Force MLA MIME Type” tab on the dropdown Help menu for the Uploads page.

    I have uploaded a new MLA Development Version dated 20200809 that contains the new option. To get the Development Version you can follow the instructions in this earlier topic:

    PHP Warning on media upload with Polylang

    It would be great if you can install the Development Version and let me know how it works for you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.