Support » Plugin: Infusionsoft Gravity Forms Add-on » Can't add a feed!

  • Resolved etellewyn


    Hi, I just discovered this plugin, and it looks like it will do exactly what we want– if it worked… However I am unable to create a new feed.

    I was able to successfully connect it to our infusionsoft account and everything was good there. But I can’t actually create a feed. When I select the form that I want to map to the infusionsoft fields, it just thinks but does not actually go any further.

    In the Javascript console, I see this error: Uncaught SyntaxError: Unexpected token <

    The location is listed as

    Another thing that might help — When I first tried it, I was initially able to create one feed, but when I saved it, I got the following error:

    Warning: Invalid argument supplied for foreach() in /home/content/95/4920295/html/cyndidale/wordpress/wp-content/plugins/infusionsoft/infusionsoft.php on line 1049

    The error appeared at the top of the field mapping page. After I saw this error I am now unable to create any more feeds (even when I delete the first feed and try to re-add it, I am not able to)

    So basically this plugin is not working at all for us right now!!

    Can somebody help?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having a similar problem.
    After I put in our API key and IS subdomain, the settings screen is blank, and I am not able to do anything else.
    No info from the javascript console.

    Using WP 3.4.1 and Gravity Forms 1.6.10

    We are using the imember360 plugin for Infusionsoft also, would that be causing a conflict?

    Update for anyone that is interested — Though I never did find an answer to my “unexpected token” issue, I did find a solution — I switched hosts! This site had been hosted on Godaddy, I’ve been bugging them to switch for some time and they finally agreed — and Bingo, the plugin worked again!

    Both hosts have the same version of php and mysql but doing phpinfo() on both hosts indicated that Godaddy had a bunch of stuff turned off that Bluehost had turned on. I have no idea which setting might have been causing the fault, but I am concluding that must be it. Maybe something worth pursuing (by somebody who knows more about this stuff than me)

    I hope this is helpful to somebody. Would be great for the developer to weigh in.

    Plugin Contributor Zack Katz


    Okay, that makes sense – the plugin uses the Infusionsoft PHP SDK, which uses curl instead of WordPress-standard wp_remote_request.

    GoDaddy has some known issues with remote fetching that WordPress has fixed, but this library apparently hasn’t. Since maintaining compatibility becomes an issue once I start messing with libraries, I decided to leave it alone and let it use curl.

    I’m on Bluehost and my problem persists. I installed the plugin, put in the API key and host and nothing but a blank screen in the config.
    I’ll try to re-install…Is there any debug procedure I could follow to find out what is going on??


    Plugin Contributor Zack Katz


    Does Bluehost support cURL?


    Plugin Contributor Zack Katz


    Well, please provide a WP login to me at and I can try to help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can't add a feed!’ is closed to new replies.