WordPress.org

Support

Support » How-To and Troubleshooting » can’t add a comment

can’t add a comment

  • just published a new website salvethought.com
    my problem is i want anybody to comment even if they are not registered to my website…i’m using wordpress 2.3.3, help pls. Do i need to edit the comment.php?

Viewing 15 replies - 1 through 15 (of 18 total)
  • I have the same issue. A lot of other users have the same problem. I have looked everywhere on these forums, but no one has provided an answer!

    No, you don’t have the same issue. It is never the same: it’s a different server, a different theme and so on.
    Always describe in details WHAT is your problem and question.
    Did you check your moderation queue?

    salve,
    does your issue persist if you switch to another theme, like the default or classic?
    Seemingly your theme doesn’t have the call for the comments template.

    i used different themes…and it’s all the same…what i want is everyone who wants to comment can comment on my blog without having to register …

    Registering or not that up to you: that depends on your settings. (Just read your own admin panel)
    I didn’t ask that.
    Can you leave it for a while with the classic or default theme?

    I came here with the same problem. WordPress 2.3.3 users cannot post comments. FYI, my administration user (me!) cannot post comments either. I have tried the default WordPress theme as well as other themes. I was hoping this thread had a solution but am disappointed to find it does not.

    I thought perhaps the host provided upgrade to 2.3.3 from the older WordPress was the problem. So I completely wiped out my /blog/ directory on the host and recreated it from a fresh WordPress 2.3.3 download. No joy. I checked the MySQL database with the host provided phpMyAdmin and all appears to be in order.

    do you have comments turned on in your admin? if they were off, or not allowed, even if you turn them on, that setting only activates them on post you make from that point on. for existing posts you need to edit them and check the box to allow comments in the ‘discussion’ box on that posts edit page.

    Comments have always been enabled on this blog.

    x Allow people to post comments on the article

    Plus the articles on which users cannot post comments have the [Allow Comments] box checked. Before I ran the update to get 2.3.3 users could post comments as there are comments from before the update. See the blog blog.eracc.com to see that comments did work at one point.

    it says
    You must login to post a comment.

    you seem to have it set to only allow logged in users to comment.

    Yes, that is correct. Makes no difference if they login or not, they can never post a comment. My administration user is logged in right now. Cannot comment on any of the articles.

    Edit: I will not allow unapproved, unregistered users to comment on my technical blog.

    just saying no one can comment doesnt really help us help you. we need more info. do you get an error? does the comment box not appear at all? do comments show up in a queue in your admin? etc.

    There is never a comment box at all.

    If I use a test user to “login” to post a comment that user sees the dashboard when logging in. Then if the user clicks the “(View site ยป)” link they go to the blog and it is as if they never logged in. They never get a comment box.

    Edit: I can create a test user called boober and let you try it. ๐Ÿ™‚

    that may help

    AH HA! I figured it out. ๐Ÿ™‚

    The blog is a subdirectory/subdomain off my main web site http://www.eracc.com. In the General Options the “WordPress address (URL):” was pointing to http://www.eracc.com/blog but the “Blog address (URL):” was pointing to http://blog.eracc.com and this apparently caused a conflict. I set them both to http://blog.eracc.com and the problem is resolved.

    Oddly enough that has not been changed since the day I first installed WordPress and comments were working in the past. Oh well, at least I figured it out. ๐Ÿ™‚

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘can’t add a comment’ is closed to new replies.
Skip to toolbar